Cannot configure AMT

Cannot configure AMT

When I try and run the ACU Wizard from the Configurator_download_package_11.0.0.214 I receive this error message, "Call to function failed with return code". I have already gone into the BIOS and setup the AMT configuration via MEBx.

I will await your suggestions. Thank you.

AttachmentSize
Downloadimage/png cant_configure_amt.PNG31.07 KB

Zone: 

Thread Topic: 

Help Me
10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

This computer may have had AMT previously configured.

Joshua,

The Wizard is pretty limited in its ability to configure AMT from within the OS. That error could have been caused by several things;

  1. Previously configured
  2. LMS.exe service was not running or missing

Joe

Thanks for the update Joe. Do you have any recommendations on how to proceed?

Joshua,

To determine if the device is currently in a configured state, search for "Intel Management and Security Status" tool. Once you open this app, select the "Advanced" tab and look for the status value: 

To determine if LMS is Installed, open up services.msc and look for "Intel(R) Management and Security Application Local Management Service", and verify it is running.

Let me know your results

Joe

Joe,

I searched for the Intel Management and Security Status tool but it is not on the computer. In addition, there is no Intel(R) Management and Security Application Local Management Service either. 

Joshua 

Hey Joshua,

If LMS isn't installed, that is the focal issue then.

The most likely reason this is issue is occurring is that the AMT device does not have an OEM OS image on it. What happens is that when windows is setting up during a custom OS installation, only the MEI driver auto installs and other necessary services do not install.

The remedy is to go to the OEM site and download the drivers for the MEI and install the complete package. Look for "chipset drivers"

Joe.

Thanks Joe, I'll look into that and get back to you with the results.

Joshua 

Joe, that fixed the issue "Call to function failed with return code". The ACU Wizard now gets to the screen which shows that AMT is configured on the system. 

With that finished, should I use the ACU Wizard in the future for configuration? Right now I have only 3-4 machines that I am setting up with AMT/KVM, but in the future all newly procured end user computers will have vPro/AMT.

Joshua

Hey Joshua,

Using ACUWizard is just one of many ways to configure the device. However any method using the OS will require the LMS, so my suggestion is as a part of your deployment process, just add in loading the OEM driver package during the onboarding process.

As you have limited devices you could easily configure via the MEBx and put the device into Admin Control Mode. By doing this method you will avoid the "User Consent" required when performing a redirection operation, such as when using KVM.

Joe

Leave a Comment

Please sign in to add a comment. Not a member? Join today