Intel ME on Broadwell-DE

Intel ME on Broadwell-DE

Hi,

We have a Broadwell-DE CPU board.

We download the Yocto BSP for Broadwell-DE and install on the board.

But we found that the mei driver cannot installed successfully.

The kernel shows 'Device doesn't have valid ME Interface'.

Any suggestion ?

Zone: 

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hey Ken

The message indicate potentially two issues

  1. Check and see if the MEI Modules are loaded

    1. sudo lsmod | grep mei
  2. In some distribution, the mei interface is shown at /dev/mei0 instead of the previously expected /dev/mei
    1. Create a soft link to fix the mapping:

      sudo ln -s /dev/mei0 /dev/mei

Joe

Hi Joe,

mei module does not appear.

/dev/mei or /dev/mei0 does not appear.

We check the code and find in 'pci-me.c', the function 'mei_me_quirk_probe()' display the message.

After some code study, we found in file 'hw-me.c' , function 'mei_me_fw_type_sps()', it will return 1 because the status is 0x000f0345.

What bother us is the status means the ME is in operational mode, but the driver will say it's not valid.

Is current mei driver in the kernel can support the Broadwell-DE CPU ?

The firmware we use is 'sps_soc-x_03.00.03.027.0_pc-gvl_rel.zip'

Thanks.

Hey Ken,

I need the following information in order to look into this further:

  • What Kernel are you using?
  • What Distribution are you using?
  • What version # of the Distro are you using?
  • In regards to the 'sps_soc-x_03.00.03.027.0_pc-gvl_rel.zip', who built that and where did it come from?

You may also want to take a look at this as it is specifically for the Broadwell - DE:

Joe

Hi Joe,

We use the Yocto distro as you provided and saw the issue.

We've also tried 'rhel-server-7.2-x86_64-dvd.iso', the same issue.

The file 'sps_soc-x_03.00.03.027.0_pc-gvl_rel.zip', it is the latest ME firmware and we got from Intel.

Thanks.

Hi Joe,

from current code,

    /* if bits [19:16] = 15, running SPS Firmware */
    return (reg & 0xf0000) == 0xf0000;

On Broadwell-DE cpu board, it will got '1' and means now running SPS firmware.

So, does it mean Broadwell-DE cpu board does not use mei driver ?

If so, any driver to support SPS firmware ?

Thanks.

Hey Ken,

I am trying to track down some information on this. I will get back to you as soon as i can

Hi Joe,

Thanks.

Hey Ken

We do not currently support the ME interface on server platforms (SPS Firmware).

So for now you will have to ignore the error message

Joe

Leave a Comment

Please sign in to add a comment. Not a member? Join today