Intel AMT remote KVM not working Q170M-C (latest BIOS and AMT FW builds)

Intel AMT remote KVM not working Q170M-C (latest BIOS and AMT FW builds)

ASUS Q170M-C running i5-6600k

BIOS=3016

AMT info:

MEBx Version    11.0.0.0010
FW Version    11.6.10.1196
LMS Version    11.6.0.1039
MEI Driver Version    11.6.0.1032
MEI DeviceID    PCI\VEN_8086&DEV_A13A&SUBSYS_86941043&REV_31\3&11583659&0&B0
SOL Driver Version    11.6.0.1009
SOL DeviceID    PCI\VEN_8086&DEV_A13D&SUBSYS_86941043&REV_31\3&11583659&0&B3

I cannot remotely (from a different computer) connect to my Q170 no matter what I do (yes i Have a monitor hooked up to it and it is in use, I'm using it now!). i also have multiple Q170s and they all work fine. i've tried:

-RESETTING BIOS on motherboard

-DISABLE & RE-ENABLE physical jumper PIN on motherboard

-Unprovision, disable AMT from BIOS and also from AMT menu many many times.

-I've used KVMControlApplication.exe (from 11.6 SDK package), Mesh Commander 0.4.2, Intel Manage Commander 1.0.8 and nothing works.

Here is an error from Intel MC 1.0.8 Error:

KVMRedirectionSAP, RequestStateChange Error 400.

Here are the workflows that has worked on many Intel AMT KVMs I've worked with previously and have been successful with:

-Within BIOS enable AMT (if not enabled)

-ctrl+p into the AMD configuration, enter default admin password, change pw and proceed to enable network IP

-I use KVMControlApplication.exe to "edit machine settings and change KVM Status to Enabled - all ports

-Then I can use any tool like VNC Viewer to connect and manage product out of band.

Are there commandline methods to change this KVM Status setting without resorting to UI? Seems like there is an issue with a variety of UI programs adjusting this 1 setting to redirect the port.

IS THIS a HW-component issue?

I would like to add that when I first purchased and stood this machine up the remote KVM worked fine. It was post 11.6 FW that it stopped working for some strange reason.

vPro Platform Solution Manager query shows:

 Exception: Attempt to use an unsupported feature: KVM is not supported by the Intel AMT device.
     Source: HLAPI
Stack Trace:    at Intel.Manageability.Impl.AMTInstanceManager.get_KVMSetup()
   at Plugins.IDER.ctrlIDERDetails.OpenSessionExists()
   at Plugins.IDER.ctrlIDERDetails.checkAllowStates()
   at Plugins.IDER.ctrlIDERDetails.CheckIfSourceProvided()
   at Plugins.IDER.ctrlIDERDetails.UserControl_Loaded(Object sender, RoutedEventArgs e)
   at System.Windows.RoutedEventHandlerInfo.InvokeHandler(Object target, RoutedEventArgs routedEventArgs)
   at System.Windows.EventRoute.InvokeHandlersImpl(Object source, RoutedEventArgs args, Boolean reRaised)
   at System.Windows.UIElement.RaiseEventImpl(DependencyObject sender, RoutedEventArgs args)
   at System.Windows.UIElement.RaiseEvent(RoutedEventArgs e)
   at System.Windows.BroadcastEventHelper.BroadcastEvent(DependencyObject root, RoutedEvent routedEvent)
   at System.Windows.BroadcastEventHelper.BroadcastLoadedEvent(Object root)
   at MS.Internal.LoadedOrUnloadedOperation.DoWork()
   at System.Windows.Media.MediaContext.FireLoadedPendingCallbacks()
   at System.Windows.Media.MediaContext.FireInvokeOnRenderCallbacks()
   at System.Windows.Media.MediaContext.RenderMessageHandlerCore(Object resizedCompositionTarget)
   at System.Windows.Media.MediaContext.RenderMessageHandler(Object resizedCompositionTarget)
   at System.Windows.Threading.ExceptionWrapper.InternalRealCall(Delegate callback, Object args, Boolean isSingleParameter)
   at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(Object source, Delegate callback, Object args, Boolean isSingleParameter, Delegate catchHandler)
  

PS Could this be a HW component issue?

I should also note that event log show NOTHING at all. All clear nothing NEW vs. all the other event logs I've seen. HW FW upgrade corruption?

Zone: 

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

i figured out what is wrong!!!!

http://www.pcworld.com/article/2976604/components/intel-skylake-all-the-...

^look at the charts... i5-6600K does *NOT* support vPro!

there are only a few processors that do :(

*sigh*...

Best Reply

Greetings

I am glad you figured it out and you seem to have a good grasp on the steps. But to clarify in order to enable AMT KVM, you must have a device that is vPro compliant by having the CPU, chipset and BIOS all enabled. As you found the processor in this case was non compliant.

a bit frustrating.. as it cuts down on the various choices of CPUs that are available for customers. not we are locked into SPECIFIC price-points... i really wished the entire 6th gen was vPro capable vs. handpicked processors.

thank you!

Just to clarify: I have the same mainboard Asus Q170M-C together with an Intel CPU i7-6700, and Intel AMT is working fine.

i ended up getting that processor too and AMT works.

the problem is you have to lookup Intel ARK and make sure vPro is supported. i5-6600k does not support vPro not all 6th gen processors do.

Leave a Comment

Please sign in to add a comment. Not a member? Join today