Graceful Shutdown and Graceful Reset

Graceful Shutdown and Graceful Reset

Hello Everyone,

I want to execute a Graceful-Shutdown and a Graceful-Reset on a another computer, but don't get the option for it (when printing the allowed commands). I can connect to the other computer via vPro, Webbrowser (http://ip:16992) and C# programs. I am able to change the boot order and execute other power commands, but not the Graceful ones. The intel AMT firmware Version of the other computer is 9.1.2-build 1010.

Can someone help me with this or has an idea what i am missing?

Best regards,
Ben

Zone: 

Thread Topic: 

Question
14 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hey Ben,

Graceful shutdown is only available with AMT version 9 and higher. So your firmware version is just fine.

As I am not sure what tools you are using, I would suggest you use Mesh Commander as a base line tool. The WebUI does not support graceful shutdown, so that is expected.

As to c# tools, take a look at the document "Change Power State", within the article is a sample snippet you can use, just change the set property line to the Graceful Shutdown option of #12. Example:

$inputObject.SetProperty("PowerState","12") # '12' = Off - Soft Graceful

Also be aware as this command is asking for a Graceful shutdown, the command interacts with the OS, as such you will need to make sure you have a complete driver install and of course the OS must be in a usable state.

Hello Joseph,

i am using the MDTK as a tool (i just used it in the beginning to make sure i get a Connection before i started with the programming). In the end everything should be handled by the C# program.

As for my current C# program, i have just used the High Level API so far. I will test it with the article that you refered to.

Update:

I have tried out the 'Remote Control' sample that came with the download (it uses the 'SetProperty("PowerState","...). It had the same result as before, the graceful options did not work.

I also installed the Mesh Commander and tried it out. I was able to connect but not to execute the desired commands.

What exactly do you mean with 'complete driver install'?

 

Hey Ben,

If you are using custom OS builds is where you may encounter issues with drivers. What occurs is that WIndows updates only the drivers and not any of the related services. This driver is called "Intel Management Engine Interface" within device Manager.

Easy way to identify if you have the required service,  is to inspect your client for LMS.exe. In services.msc you can find it as "Intel(R) Management and Security Application Local Management Service".

If this service is not installed, look for the chipset driver from the device OEM and install the full package.

Joe

Hello Joe,

i checked the Computer that i want to remotely manage and the file and service were missing. I installed the Intel Management Engine Interface from a CD that was provided by the manufacturer. The Installation went smoothly and after Installation the file and service were on the System. The process however does not start and when i try to start manually i get this warning:

Warning when starting the LMS service manually

I also checked the Event Viewer, but there is just the Information that LMS started and right after the Information that it stopped.

I then downloaded the most recent drivers from the manufaturers Homepage but it ended with the same result.

The remote Systems Hardware is: http://new.ieiworld.com/en/product/model.php?II=178

Ben

Hey Ben,

Make sure your OS is fully up to date with all patches. The issue could easily be a missing security certificate.

To identify the certificate in question go to: "C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\LMS\LMS.exe"

  1. Find the file LMS.exe
  2. Right click the file, select properties
  3. Select Digital Signatures
  4. Select the Signature in the list
  5. Select Details
    1. Digital Signature Details window opens

      1. The second line of the general window should say "This digital Signature is OK" if LMS is to work correctly
    2. Select View Certificate
      1. Certificate Window opens

        1. Select Certificate Path
        2. One if not more of the certificates should be invalid

Joe

 

Hello Joe,

I will test it again on an up to date machine.

As for the LMS.exe on the current machine and the certificates there, they seem to be all ok.

The LMS.exe certificate:

The certificate of the LMS EXE

The Certificate view:

LMS Certificates

One Thing that i noticed was that the certificate are past their and date:

LMS Certificate End Date

But i assume that certificate will get renewed as soon as it is up to date (the Computer i want to control has a fixed patch number and is not connected to the internet).

I give an update as soon as i tested it with the up to date machine.

ben

Best Reply

Hey Ben

Great catch on the expired certificate, according to some old notes Microsoft KB931125 should fix the issue, if doing a full update doesn't actually download it as well.

Joe

Hello Joe,

I updaten the Computer and after installing the newest version of Intel ME i was finally able to start LMS.exe and also execute a Graceful Shutdown. Thank you very much for your support!

I would just have one final question, is it possible to shorten the time the computer takes to gracefully shutdown? Now it takes about one whole minute.

Ben

Hello Joe,

i would have another question. I hooked up a second computer and whenever i try to connect to it and establish a AMT connection it turns on and boots up. The other computer does not do that at all. It happens when i use Mesh Commander, the web interface and my own code.

Ben

Hey Ben,

That is certainly a strange behavior, my first suggestion would be to do a BIOS/firmware update.

What is the OEM and model of the system in Question? What was the original BIOS and what are the results of the BIOS update?

Joe

Hello Joe,

The System has this motherboard: http://new.ieiworld.com/de/product/model.php?II=178

The BIOS on the machine is the latest one. and when i try to execute the update provided by the manufaturer i get an error that complains about the os not being x64 despite it being one.

What iritates me is, that the two machine i have for testing (one of whitch is causing this Problem) are identical, one is working fine and the other is not. A coworker suggested that i try a BIOS reset and i will try that when i got some spare time again.

Ben

Hey Ben,

Unfortunately I do not have any experience with the OEM, so I don't have platform  specific insights.

However I would suggest resetting the BIOS to factory defaults and pulling the CMOS battery. That will reset you MEBx to factory defaults and you can then start fresh and see if the behavior continues.

Joe

 

Hey Joe,

i will try that if it comes up again, i was not able to do it on the machines i had since i had to give them back already. It was a research project after all and i am already assigned to a new Project.

Thanks for your time, it really helped a lot!

Ben

Leave a Comment

Please sign in to add a comment. Not a member? Join today