"compilervars.sh ia32" doesn't work?

"compilervars.sh ia32" doesn't work?

I'm using 64-bit Arch Linux, and just installed the non-commersial version of Intel C++ 2011 XE (c_studio_xe_2011_update2.tgz, around 1.4 GB, which does 32 & 64 bit). In /opt/intel/bin, I tried "./compilervars.sh ia32", and when I compiled a simple code:#include int main(){printf("ICC test...\\n");return 0;}Then I tried to use "-m32" paramater, and the result was:catastrophic error: Compiler configuration problem encountered. The expected target architecture compiler is missing (12.0-ia32 != 12.0-intel64)compilation aborted for test.c (code 1)What should I do, so I can generate 32-bit code properly?

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

You need '.', a space and then the full path to 'compilervars.sh'.

You should cd to a user owned directory where you have permissions to read and write files, then, as mecej4 said, source the compilervars script. The compiler won't work for compiling in its own installation directory; at least not with standard permission settings.

Leave a Comment

Please sign in to add a comment. Not a member? Join today