64 bit Linux: could not read symbols: Archive has no index; run ranlib to add one

64 bit Linux: could not read symbols: Archive has no index; run ranlib to add one

I am building a shared library for both 32 bit and 64 bit Linux. Main module is compiler with g++; It in loads a static library created with Intel Composer XE C++ 2011 for Linux. All elements are built in release modeAll this works fine under ia32. However, under intel 64, the link step fails as follows;g++ -L"/home/spyder/IntelCompiler/BalsamDLL/Release" -L/opt/intel/mkl/lib/intel64 -L"/home/spyder/IntelCompiler/btImage/Release" -L"/home/spyder/IntelCompiler/chipimaging/Release_i" -L"/home/spyder/IntelCompiler/utilitieschipimaging/Release" -pthread -Wl,-rpath,/opt/intel/mkl/lib/intel64 -shared -o"libChipImagingWrapper.so" ./ChipImagingWrapper.o -lpthread -lmkl_core -lmkl_sequential -lBalsamDLL -lm -lmkl_intel_lp64 -lrt -lchipimaging -lbtImage -lutilitiestest/home/spyder/IntelCompiler/chipimaging/Release_i/libchipimaging.a: could not read symbols: Archive has no index; run ranlib to add oneI have tried running ranlib and also running xiar with -s flag to no avail.Any suggestions?

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi
??? Is used normally for old version but maybe test with added flag -fPIC as first (g++ -fPIC .......)
(xiar & xild) only if you have use ipo i think ??
regards

Problem was -S option was selected (Source code)

Linux no utiliza el codigo ascii en el teclado como lo podemos hacer en windows.

JudLup Luna

Leave a Comment

Please sign in to add a comment. Not a member? Join today