Composer XE 2011 Update 1 integration problem with VS2010

Composer XE 2011 Update 1 integration problem with VS2010

Hi,
Ihave installed the Composer XE 2011 Update 1 for Windows (Package ID: w_ccompxe_2011.1.127) and I choose to integrate it with VS2010 Ultimate (10.30319.1 RTMRel).Mymachine runs Windows 7 64-bit Enterprise.

The problem I am facing with is that I cannot switch to Intel compiler from Visual Studio IDE the way as video tutorial is suggesting. I disabled all the plugins but this does not helped. The installation process did not reported any issues. The VS2010 About Box shows that the Intel compiler is installed (Intel C++ Composer XE 2011 Package ID: w_ccompxe_2011.1.127).

I see inHelp menu"Intel C++ Composer XE 2011 -> Intel C++ Composer XE Help..." and it's accessible.

There's no Intel C++ Composer XE menu item in Project submenu, as help is suggesting. Moreover the Options dialog box is displaying "Intel C++" branch, but when I am clicking on it I get "There are no Intel C++ Compilers installed." message.

When I try to use the Composer XEona file (Context Menu->Intel C++ Composer XE 2011->Use Intel C++ for selected file(s)...) I get the "Use Intel C++" dialog box where drop down box labeled "Select the Platform Toolset" says "No Intel C++ Platform Toolsets installed"

The ComposerXE log files has been attached.

Thanks,
Artur

12 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

In case you haven't checked:
Did you install ICL for Intel64, for which you had to first install MSVC++ for X64? Then you would have to choose X64 mode for your project, to make that Intel C++ accessible.
If you install MSVC++ and ICL 32-bit versions, you should be able to switch to Intel C++ without switching to X64 build, but that may not be what you want.

I have ICL installed for botharchitectures (Intel64 and 32bit). The same with MSVC++. The problem I am observing is independent from architecture model I choose.

I have VTune AmplifierXE 2011 Update 1 and Inspector XE 2011 Update 1installed, too.

I solve the problem. The folder "Intel C++ Compiler XE 12.0" and the content was missing from PlatformToolsets directory in following location.C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\Win32\PlatformToolsetsC:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Platforms\x64\PlatformToolsetsOnce I copy the folder and content from the machine that did not have this issue, all is working as expected. It looks like the problems with permissions during the installation process, but the installer did not warn me about this.

Visual Studio installer, which you would have to run to install those, always requires UAC, in effect, run as administrator.

I did run the installer as an administrator and when UAC asked me for the requiredprivilegesI granted them to the installer.One question: could it be possible that the integration failed because I have only C++ component installed (no C# nor F# and VB)?

Hi @all

I've got a similiar problem with all version of Intel C++ Composer up to the brandnew Update 2.

I've installed Visual C++ 2010 Professional (German edition) and installed the C++ Composer.

The latter integrated well into VS 2008 and 2005 and didn't show any error regarding its 2010 integration.

But there are no signs of an VS 2010 integration (of course I've checked it during installation process).

When opening the VS 2010 About dialog, it shows Intel Visual Fortran, the Intel Inspector and Intel VTune but no signs of the C++ Composer.

Any ideas for this problem?

Regards

Andreas

I think you aren't getting attention, because you appended new questions to a thread marked SOLVED. Presence or absence of C#, F#, and VB should have no influence on Intel compiler installation, unless it affects disk space.

Yes, you would require the C++ component specific to VS2010, in addition to the others, for the integration to complete. If you don't have a reason for requiring VS2010, VS2008 SP1 may be superior.
As you intended this to be a new topic, it might have received earlier attention if posted separately.

Hi Tim,

what do you mean with "require the C++ component specific to VS2010 ... for the integration to complete".
I just checked the VS2010 integration as well as the others for 2008 and 2005 to be installed side by side.

Do I have to perform any additional steps to get the 2010 integration working?

Best regards
Andreas

Hi again,

I opened a new thread for this issue because this one is labeled as SOLVED.

Leave a Comment

Please sign in to add a comment. Not a member? Join today