error with C++ Composer 2011 installation

error with C++ Composer 2011 installation

when i test c++ composer xe , a erroroccur while installing at position 13/16 in windows xp,the error screen and log in attached file. help me. thanks.

AttachmentSize
Downloadapplication/x-7z-compressed ComposerXE2011.7z0 bytes
14 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Let me go through your log file to see what I can find and let you know shortly.

About the error screen you attached, it's not from our installation. It's probably from your internet browser.

Thanks,
Jennifer

I thought it might be related to something known, but no.

So please provide some more info about your system.
1. OS: 32bit or x64
2. temp dir (open a cmd window from start, and type "set" and it displays all the env-var value, Find the Temp and paste here)
3. VS version and edition (English or Chinese, express or pro etc.)
4. the full pkg name (.exe file name)

(btw. The image does not relate to this issue, it's likely a posting problem, so I've removed it. If you have a screen-capture of the error dialog, please attach it.)

Thanks,
Jennifer

Ok. I think your issue is the same as this known issue - http://software.intel.com/en-us/articles/fail-to-install-composer-xe-2011-on-system-with-visual-studio-2005/

Please try the work-around to confirm.

thanks,
Jennifer

the error msg window,belowOS :windows xp prof 32bit chinesecpu:core2 t5250env set:belowC:\Documents and Settings\Administrator>setALLUSERSPROFILE=C:\Documents and Settings\All UsersAPPDATA=C:\Documents and Settings\Administrator\Application DataBCG=D:\BCGSoft\BCGControl12BISTRO_GLOBAL_CACHE_DIR=D:\Intel\VTune\CGGlbCacheBOOST=D:\boost_1_42_0CLASSPATH=.;D:\Java\jre6\lib\ext\QTJava.zip;C:\Program Files\Common Files\Compuware\DLM40JNI.jar;D:\Java\jdk1.6.0_21\lib\tools.jarCommonProgramFiles=C:\Program Files\Common FilesCOMPUTERNAME=IBM-CAComSpec=C:\WINDOWS\system32\cmd.exeDDK=D:\WinDDK\7600.16385.0devmgr_show_nonpresent_devices=1DRIVERNETWORKS=D:\Compuware\DriverStudio\DriverNetworksDRIVERWORKS=D:\Compuware\DriverStudio\DriverWorksDXSDK_DIR=D:\DX9SDK\FP_NO_HOST_CHECK=NOHOMEDRIVE=C:HOMEPATH=\Documents and Settings\AdministratorICPP_COMPILER11=D:\Intel\Compiler\11.1\067\INTEL_LICENSE_FILE=C:\Program Files\Common Files\Intel\LicensesJAVA_HOME=D:\Java\jdk1.6.0_21KMP_DUPLICATE_LIB_OK=TRUELM_LICENSE_FILE=d:\pgi\pgroupd.licLOGONSERVER=\\IBM-CANMSYMPATH=D:\Compuware\DriverStudio\SoftICENUMBER_OF_PROCESSORS=2OS=Windows_NTPath=D:\Python26\Scripts;D:\Python26\;D:\Intel\Media SDK\1.0.11.12792G\bin\win32;D:\Intel\Media SDK\1.5.11.17934\bin\win32;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\ProgramFiles\PC Connectivity Solution\;D:\Intel\VTune\CGGlbCache;D:\Intel\VTune\Analyzer\Bin;D:\Intel\VTune\Shared\Bin;D:\Intel\Compiler\11.1\067\bin\ia32;C:\ProgramFiles\Microsoft SQL Server\80\Tools\BINN;C:\Program Files\Common Files\Lenovo;D:\Borland\Delphi6\Bin;C:\Program Files\Common Files\Thunder Network\KanKan\Codecs;C:\Program Files\NASM;C:\Program Files\QuickTime\QTSystem\;D:\php5.2.12;D:\GNU\cvsnt;C:\WINDOWS\system32\WindowsPowerShell\v1.0;C:\Program Files\Sybase\Shared\PowerBuilder;C:\Program Files\XYB7;C:\Program Files\Common Files\Compuware;C:\Program Files\Microsoft SQL Server\90\Tools\binn\;C:\Program Files\Microsoft SQL Server\80\Tools\Binn\;C:\Program Files\Sybase\Shared\DataDirect;C:\Documents andSettings\Administrator\Application Data\Python\Scripts;D:\BCGSoft\BCGControl12\Bin;D:\Microsoft SDKs\Windows\v6.1\bin;d:\borland\BC5\BIN;C:\Program Files\The KMPlayer\Codec;C:\Program Files\The KMPlayer;D:\BCGSoft\BCGControl12\Bin;D:\Google\google_appengine\;D:\Program Files\TortoiseSVN\bin;D:\Program Files\CVSNT\;D:\PGI\win32\10.0\bin;D:\STLport-5.2.1\bin;D:\3rdLib\OpenCV2.0\binPATHEXT=.COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH;.PSC1;.py;.pywPGIBIN=D:\PGI\win32\10.0\binPGROUPD_LICENSE_FILE=d:\pgi\license.datPROCESSOR_ARCHITECTURE=x86PROCESSOR_IDENTIFIER=x86 Family 6 Model 15 Stepping 13, GenuineIntelPROCESSOR_LEVEL=6PROCESSOR_REVISION=0f0dProgramFiles=C:\Program FilesPROMPT=$P$GPSDK=D:\Microsoft SDKs\Windows\v6.1PSDKXP=C:\Program Files\Microsoft SDKs\Windows\v6.0APSModulePath=C:\WINDOWS\system32\WindowsPowerShell\v1.0\Modules\QTJAVA=D:\Java\jre6\lib\ext\QTJava.zipREM_LINK_REPRO=C:\logSDL=D:\3rdLib\SDL-1.2.14SESSIONNAME=ConsoleSTLSOFT=D:\3rdLib\stlsoft-1.9.97SYBASE_LICENSE_FILE=C:\Program Files\Sybase\PowerDesigner 15\Tools\license.licSystemDrive=C:SystemRoot=C:\WINDOWSTEMP=C:\TempTMP=C:\TempTPCCommon=C:\Program Files\ThinkVantage\PrdCtrTSMPATH=C:\Program Files\ThinkPad\UltraNav UtilityTVT=C:\Program Files\LenovoUSERDOMAIN=IBM-CAUSERNAME=konghengUSERPROFILE=C:\Documents and Settings\AdministratorVCToolkitInstallDir=D:\Microsoft Visual C++ Toolkit 2003\VOLE_ROOT=D:\3rdLib\vole-0.6.6VS10=D:\Microsoft SDKs\vc10VS60COMNTOOLS=D:\Microsoft Visual Studio 6\Common\ToolsVS80COMNTOOLS=D:\Microsoft Visual Studio 8\Common7\Tools\VS90COMNTOOLS=d:\Microsoft Visual Studio 9.0\Common7\Tools\VTOOLSD=D:\Compuware\DriverStudio\VtoolsDVTUNE_GLOBAL_DIR=D:\Intel\VTune\global_data\windir=C:\WINDOWSWise_QuickFacts=C:\Program Files\Altiris\Wise\Tutorial\QuickFacts\vs: vs2005 team suite chinese & vs2008 team system chinesefull pkg name:w_ccompxe_ia32_2011.0.104.exe

did you try the work-around in my previous posting? does it help?

Thanks,
Jennifer

Hello,

About the error msg dialog you attached again, it is an image from QQ website. I'm sure it's not from any installation error. so it's very strange that you see this image while our installation fails.

could you give me some more details on what you saw? how do you know the installation failed? what did you do to close the installation program?

Thanks,
Jennifer

Ok. I finally saw the error msg dialog from my fellow colleague. The error is from the IDE integraton module.

can you open c:\windows\syswow64\cmd from "start", and try "regsvr32 /?" to see if it runs? if not, the "path" is bad.

Jennifer

I can't find folder "c:\windows\syswow64" in my system ,is it in xp prof?regsvr32 in c:\windows\system32 in my system and run correcttly.
I tried deselect "Intel Parallel Debugger Extension" in installation, but not usefull,the error continued.another Intel c++ 11.1.067 installed in my system, and not integrated with vs.is it the reason?

Could you try following?
1. clean the "path" env-var so it's shorter. I'm afraid that during the installation the cmd window with newly added directories, the "c\windows" maybe pushed out.
2. try to install again
3. if does not work, could you download/install the new update 1 full pkg "w_ccompxe_2011.0.127.exe"?

At the same time I'm checking with our engineers on other possible reasons.

Thanks,
Jennifer

I make shorter env "path",and uninstall intel c++ compiler prof 11.1.067.unfortunately ,the error continued, so I reinstall intel c++ compiler prof 11.1.067, my ghost,another error occured. the error msg window attached.then I installw_fcompxe_novsshell_2011.0.104.exe andw_ccompxe_2011.0.104 ,but the same error occured.


Now I have none Intel compiler.Need I to repair my vs?

THe error is related to Windows installer msi. But if the msi has a problem, why other .ms files can be installed fine.
Could you try to repair your installer with the instruction herehttp://support.microsoft.com/kb/315346to see if it helps?

I repaired My Windows installer ashttp://support.microsoft.com/kb/315346the version is4.5.6001.22159and I installed vs2010 ultimatethen I deselect integration with vs2005 & vs2008The error continued yet.but about a month ago 11.1.067 installed corrected.

Posting the solution here:

I down windows installer to version 3.1 successfully,then Installed Intel c++ Composer 2011 correctly.

This issue only happens in some special cases and in such cases, downgrading the installer to 3.1 version solves the problem.

Jennifer

Leave a Comment

Please sign in to add a comment. Not a member? Join today