Reinstalling Intel Composer XE 2011 for Linux

Reinstalling Intel Composer XE 2011 for Linux

I'm having trouble re-installing version 12 of the compiler (via Intel Composer XE 2011 for Linux) after previously removing an install.
The sequence of events was as follows:

1) Installed Intel Composer XE 2011 on Fedora 14 to a fresh /opt/intel directory
2) Decided I wanted to roll back to version 11.1, so I deleted /opt/intel directory
3) Installed 11.1 to fresh /opt/intel directory
4) Changed my mind again, wanted to return to v12, so I deleted /opt/intel directory
5) Attempted to install Intel Composer XE 2011 to fresh /opt/intel directory, but I receive the message ->

"The Intel Composer XE 2011 for Linux* is already installed.

If you want to reinstall the Intel Composer XE 2011 for Linux*
please uninstall current version and run install script again."

What remnant of the previous install is it detected, and how do I resolve this?

Thanks

34 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Steven,

You can't delete old version folder directly.
Please read release_notesC.pdf in 2.3 section about Removal/Uninstall for more details.

Thanks,
Wise

I should have seen this information earlier. But I deleted the compose directory for fortran directly. Then what can I do in this case?

And I installed Ccomposexe then, no script called uninstall found. If there is somewhere keep some information about the installation?

I am having the same problem. Tried to reinstall Fortran Composer XE 2011 for Linux after deleting original /opt/intel directory but continue to get request to uninstall previous. I have the uninstall script for an 11.1 installation, but that only want to uninstall 11.1 components. How do I wipe the slate clean and start over?

Please try the following:

1. Download the uninst_12.0.084.tgz attachment from this reply and place on your system in /tmp
2. Become root (su or sudo), thencd /tmp
3. Unpack the file: tar -zxf uninst_12.0.084.tgz
4. Change into the new sub-directory: cd uninst_12.0.084
5. Execute the script: ./uninstall.sh

Please let me know if this is successful.

Kevin

Unfortunately, it didn't solve the problem. I ran the script as you advised, and asked it to uninstall all components. It seemed to run correctly, but when I tried the reinstall, I still get the same message to uninstall first. I ran your script again and this time it couldn't find anything to uninstall, which makes sense. It seems there is a signature of the previous install still buried somewhere on the system. I even deleted relevant messages in /var/log, but this didn't help.

T. Rosmond

Kevin,

I just noticed your script was for the 084 release, but I am trying to install release 107. That must be a problem, correct?

T. Rosmond

Ok, so you have XE 2011 Update 1. It may matter. I'll bundle that and post shortly.

Quoting Kevin Davis (Intel)

Ok, so you have XE 2011 Update 1. It may matter. I'll bundle that and post shortly.

Kevin, could you please post that file asap as I have the same problem with uninstalling onXE 2011 Update 1. Thank you!

Quoting Kevin Davis (Intel)

Ok, so you have XE 2011 Update 1. It may matter. I'll bundle that and post shortly.

up

There may be issues with obtaining file uploads within private replies. So, let's try this public post too. Let me know if you get the file from here or the ftp.intel.com.

(Updated 12/10/2010: Attachment was removed)

Quoting Kevin Davis (Intel)

Ok, so you have XE 2011 Update 1. It may matter. I'll bundle that and post shortly.

Kevin,

I see your recent post that refers to 'uninst_12.1.107a.tgz'. I can't seem to download from that attachment. How can I get it?

T. Rosmond

Kevin,

Did this issue ever get resolved? I still haven't been able to re-install XE 2011 Update1.

T. Rosmond

Hi T. Rosmond.

Yes it was resolved. Sorry for not seeing your earlier private post. We are not receiving notification of private replies in all cases.

I am private again here to share the details with you on how to resolve this.

Attachment downloads from the Forum are also still not fully functional, so grab the file from ftp.intel.com here: ftp://ftp.intel.com/pub/outgoing/uninst_12.1.107a.tgz

Next, following these instructions and make sure you do them as "root":

1. Download the uninst_12.1.107a.tgz and place on your system in /tmp
2. Unpack the file: tar -zxf uninst_12.1.107a.tgz
3. For files that should be in /tmp/uninst_12.1.107a, change the owner and group to be "root" using:

chgrp -R root /tmp/uninst_12.1.107a
chown -R root /tmp/uninst_12.1.107a

4. Next, create a directory with this command: mkdir -p /opt/intel/composerxe-2011.1.107/bin
5. Now copy the files into this directory with: cp -pR /tmp/uninst_12.1.107a/* /opt/intel/composerxe-2011.1.107/bin/
6. Now execute uninstall.sh using the full path like this: /opt/intel/composerxe-2011.1.107/bin/uninstall.sh

Keep me posted.

Kevin,

Thanks for replying. Unfortunately it looks like too much time has elapsed (only 24 hours according to the banner on the Intel ftp server), so uninst_12.1.107a.tgz is gone. Could you please put the file back and then notify me via e-mail (rosmond@reachone.com) so I can jump in and get the file before it vanishes again.

Thanks,

T. Rosmond

Hi T. Rosmond,

I re-posted the file below to this forum thread reply, included a copy in the e-mail sent the address requested, and placed it onto ftp.intel.com at: ftp://ftp.intel.com/pub/outgoing/uninst_12.1.107a.tgz

Hopefully you can obtain it from one of these three options. Keep me posted.

Updated: User confirmed obtaining the file, un-installing/re-installing successfully. Attachment was intentionally removed.

Hi All, Kevin,
The file is gone again - can you repost and will this be fixed in future versions of Composer? I tried to move directories where I installed the software and it has turned into a nightmare trying to get rid of it - I've tried deleting everythin I can think of, I would have had to reinstall the OS if I couldn't fix this - Thanks!
David

As I indicated, I intentionally removed the file. I don't want to leave it posted permanently.

There's nothing to fix since there's nothing broken. One cannot remove or movethe software without using the uninstall/install scripts.People are getting into troubleby removing the software with 'rm' and that's insufficient. The uinstall script performs a complete removal.

Ire-posted the file to this reply. If you did not install in /opt/intel and you are not using the 107 update, that matters, so please let me know the custom directory name and update you have.

Updated: User confirmed obtaining the file, un-installing/re-installing successfully. Attachment was intentionally removed.

Hey,i have also done the same mistake like you have done.But get rid of this problem by doing this.

  1. Just use your Package Manager (e.g. gnome package manager or yum )and search for the "intel"
  2. Remove all software related IntelC++ Compiler, IntelMath Kernel Library, debuggers, composer X etc.
  3. Then try to install "Intel Composer XE 2011 for Linux"

Best of luck::

I am also having no success uninstalling the package. However I have not deleted any directories in /opt/intel. I have read section 2.6 of the "Installation Guide and Release Notes", and I have no such subdirectory as ia32 (i am 32 bit), and there is no 'uninstall_cprof.sh' script on my machine.

Kevin, could you please re-post the uninstall script? I don't want to reinstall my OS.

The uninstall information in the Release Notes is incorrect. The uninstall_cprof.sh/uninstall_cproc.sh were used in 11.x and are not used in Composer XE for Linux.

Forthe C++ Composer XE update 1 (2011.1.107) for Linux, the default installation directory would be: /opt/intel/composerxe-2011.1.107. Under there one would find the 'bin' sub-directory where only a uninstall.sh resides.

If you still do not find the uninstall.sh then you can try the attached script. You should be able to follow the steps in my earlier reply #34 (here).

Attachments: 

AttachmentSize
Downloadapplication/x-gtar uninst_12.1.107a.tgz15.84 KB

I do not see the attachment. Am I missing something? (Never mind - I was looking at this reply under some other thread. Found it now)

Hello,

I have installed the Fortran compiler called "Intel Composer XE 2011 Update 2 for Linux" on a Sun server (x86_64) into /usr/local/intel because of tight space in /opt. The directory created was /usr/local/intel/composerxe-2011.2.137

During the installation, I have constated that all the Itanic versions are being installed and tried to stop the script with Ctrl-C. It did not stop.

At the end, I said myself, not a big deal, I will erase /usr/local/intel and re-run the install.sh script.

However, now it says:

The Intel Composer XE 2011 Update 2 for Linux* is already installed.
If you want to reinstall the Intel Composer XE 2011 Update 2 for Linux*
please uninstall current version and run install script again.

So I have downloaded the uninst_12.1.107a.tgz, unzipped, changed the owner and group to root, placed into /usr/local/intel/composerxe-2011.2.137/bin and run. It said:

Unable to find any components to uninstall, probably package has been installed by another user, removed manually or corrupted.
Please see "/var/log/intel-compilerpro-107-12.0-1_uninstall.log" for uninstallation details.

In the log file, a lot of entries, nothing found to uninstall. However the install.sh script still says "already installed". Horribly overengineered, out of control. Server re-install is too costly, have to find a solution.

Any suggestion?

If you deleted the uninstall script associated with the installation you started, and don't want to wait for someone to supply you with a specific cleanup script, you can fall back on the linux tools (rpm, if that's the install method for your distro)
rpm -qa | grep intel
for any Intel software tools you want cleaned out of rpmdb
rpm -e If you havea GUIpackage manager, maybe that has options to remove database entries.

Thank you Tim, it worked. I have found the following packages:

% sudo rpm -qa | grep -i intel
intel-compilerpro-devel-137-12.0-2
intel-compilerpro-devel-137-12.0-2
intel-mkl-common-137-10.3-2
intel-compilerprof-devel-137-12.0-2
intel-sourcechecker-devel-137-12.0-2
intel-mkl-137-10.3-2
intel-compilerpro-common-137-12.0-2
intel-compilerprof-137-12.0-2
intel-openmp-137-12.0-2
intel-compilerprof-devel-137-12.0-2
intel-idb-137-12.0-2
intel-mkl-devel-137-10.3-2
intel-openmp-devel-137-12.0-2
intel-compilerprof-common-137-12.0-2
intel-sourcechecker-devel-137-12.0-2
intel-compilerprof-137-12.0-2
intel-idbcdt-137-12.0-2
intel-mkl-137-10.3-2
intel-openmp-137-12.0-2
intel-sourcechecker-common-137-12.0-2
intel-idb-common-137-12.0-2
intel-mkl-devel-137-10.3-2
intel-compilerpro-vars-137-12.0-2
intel-openmp-devel-137-12.0-2
intel-idb-137-12.0-2

% sudo rpm -e intel-compilerpro-devel-137-12.0-2
error: "intel-compilerpro-devel-137-12.0-2" specifies multiple packages

% sudo rpm -e intel-mkl-common-137-10.3-2
error: Failed dependencies:
intel-mkl-common-137 is needed by (installed) intel-mkl-devel-137-10.3-2.i486
intel-mkl-common-137 is needed by (installed) intel-mkl-devel-137-10.3-2.x86_64

We see that there may be two versions, for $a.i486 and $a.x86_64 where $a is the name of the package.
So I wrote a robust script that first erases $a.i486 then $a.x86_64 and finally $a. I had to re-run it more than once because of dependencies, until rpm -qa was empty.

The compiler install was now correct. One just has to read carefully what the installation script says.

I did a non-root installation and it put an rpm database in ~/intel. I rm'd this dir and the install dir and I can now reinstall.

Dear Kevin,

I have the same problem. I am installing the Intel compiler, and I obtain:

--------------------------------------------------------------------------------
The Intel Composer XE 2011 Update 4 for Linux* is already installed.

If you want to reinstall the Intel Composer XE 2011 Update 4 for Linux*
please uninstall current version and run install script again.
--------------------------------------------------------------------------------

I have used the scripts included in uninst_12.1.107a.tgz, but I did not solve the problem.
What can I do?
If I need any new script or software, please write me to norge@us.es.

Thanks !!!!

The earlier attached script is not universal to any release. It is specific to theIntel Composer XE 2011 Update 1and having installed under /opt/intel.

For your case, generate a list of Intel Composer XE 2011 Update 4 RPMs using the following command:

rpm -qa | grep intel | grep 191

Save that list away somewhere in case it is needed.

Next, as root,remove all Intel Composer XE 2011 Update 4 related RPMs using the following command:

rpm -e --allmatches `rpm -qa | grep intel | grep 191`

Please NOTE: The use of back-quotes in the command above are significant. Be sure to include them.

Once that rpm command completes, then re-try the installation.

How can I download the uninst_12.0.084?.. there is no link or attacthment.Please help.

The earlier download file was remove. The script should not be necessary. The method in reply #49 should also work for your case.Please tryusing that method and replacing "191" with "084".

Hello Guys!

I Would like to remove the Intel Composer XE 2013, because i think my installation is not correct, more specific the location, because don't appears the /opt directory. Do You have any idea?

Hey guys I had the exact same issue. I was so confused until I found this link : https://software.intel.com/en-us/articles/uninstall-intel-compiler-for-l...

This makes for a very easy fix!!!!

Thanks Peter/all. BTW, here's an article I'd written sometime ago as well on the same issue: https://software.intel.com/en-us/articles/uninstalling-intel-software-development-products-linux 

_Kittur

Leave a Comment

Please sign in to add a comment. Not a member? Join today