problem with enviroment variables

problem with enviroment variables

i use ubuntu 10.10
intel c++ compiler ia32 was successful installed,
but when i try to set enviroment variables i receive errors:

root@sh:/opt/intel/bin# ./ ia32
/opt/intel/composerxe-2011/tbb/bin/ 38: [[: not found
/opt/intel/composerxe-2011/mkl/bin/ 12: Bad substitution

may you give me some tips?

13 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

You must source the environment script, not run it as a shell script.
You shouldn't need to source all the individual scripts; they are meant to be run from the top level.
If you're running under tcsh or some other cshell compatible shell, simply change to the compilervars.csh
source /opt/intel/composerxe-2011/bin/compilervars.csh ia32
(or iccvars.csh, if that's what's present)

well, csh isn't my script , my script is .sh, i see this error
./iccvars.csh ia32
./iccvars.csh: 36: syntax error: unexpected end of file

i have moved to the source /opt/intel/composerxe-2011/bin/, what should i type there and where?
and what does source mean?

may be, should i something write in ?

but i don't know what exactly

# Copyright (C) 1985-2010 Intel Corporation. All rights reserved.
# The information and source code contained herein is the exclusive property
# of Intel Corporation and may not be disclosed, examined, or reproduced in
# whole or in part without explicit written authorization from the Company.


if [ "$1" != "ia32" -a "$1" != "intel64" ]; then
echo "ERROR: Unknown switch '$1'. Accepted values: ia32, intel64"
return 1;

if [ -e $PROD_DIR/pkg_bin/ ]; then
. $PROD_DIR/pkg_bin/ $1
if [ -e $PROD_DIR/tbb/bin/ ]; then
. $PROD_DIR/tbb/bin/ $1
if [ -e $PROD_DIR/mkl/bin/ ]; then
. $PROD_DIR/mkl/bin/ $1 $2
if [ -e $PROD_DIR/ipp/bin/ ]; then
. $PROD_DIR/ipp/bin/ $1
if [ -e $PROD_DIR/pkg_bin/ ]; then
. $PROD_DIR/pkg_bin/ $1

Actually both and set the same environment variables. You should be able to set the environment variables by doing:

source /opt/intel/composerxe-2011/bin/ OR
source /opt/intel/composerxe-2011/bin/

Make sure the ttb and mkl directories referenced in the original errors you were getting do exist. They should not be needed if you are not going to use tbb andmkl libraries. So you should be able to use the compiler (e.g. icc -c file.c)after sourcing the above scripts even if you get errors abouttbb and mkl environmentsetting.


i don't know what i do wrong. i want to use intel compiler, but i can't solve this problem. my teachers in the university don't know anything about intel compiler. i don't know anybody who can help except this forum

Sorry, I missed ia32 argument, the command should be:

source /opt/intel/composerxe-2011/bin/ ia32

Do you still get the same errors when you execute the above command?

Do the tbb and mkl direcotiries exist in your installation?

Does doing "icc -V" command work after executing the above command?


thank you. i don't know what i'll do without your help . it was very simple. i couldn't understand meaning translate's word 'source'. but i should just type this command.
thanks guys

Looks like your issue is resolved. Just for your information, we currently support Ubuntu 10.04. But usually, a minor version update should not cause problems. You can find details at

Ubuntu has a Long Term Support version where they will support it for a
long time. This was 10.04. 10.10 is a update release and will not
have long term support, meaning it will be superceded by the next update or LTS
release and dropped.

Ive heard quite a few posts on the net about 10.10 problems and general
unhappiness with this release. Would not surprise me if something was


o no, in my case all is the well with Ubuntu 10.10
thank you for support

"Does doing "icc -V" command work after executing the above command?"-

Yes, it's work

Hello Friends,
I am New in intel composer_xe, I have Install intelSDK and I am tring to set envornment vaiable of IntelSDK my installation path is :

when I am executing following command:
root@swapnil-lp:/opt/intel/composer_xe_2013/bin# ./ intel64
./ 24: /opt/intel/composer_xe_2013/tbb/bin/ [[: not found
./ 39: /opt/intel/composer_xe_2013/ipp/bin/ [[: not found

I got such error I am using Ubuntu12.04 I have tried all above solution. But still iam facing this problem.

These environment scripts are to be sourced, not run as a script:
source /opt/intel/composer_xe_2013/bin/ intel64
The compilervars script sets up the tbb and ipp, if they were installed along with icc.

Hi TimP (Intel)
My Installation path is /opt/intel/
but still my problem waiting for solution:
swapnil@swapnil-lp:~$ /opt/intel/composer_xe_2013/bin/ intel64
/opt/intel/composer_xe_2013/bin/ 24: /opt/intel/composer_xe_2013/tbb/bin/ [[: not found
/opt/intel/composer_xe_2013/bin/ 39: /opt/intel/composer_xe_2013/ipp/bin/ [[: not found
swapnil@swapnil-lp:~$ cd /opt/intel/composer_xe_2013/tbb/bin/
swapnil@swapnil-lp:/opt/intel/composer_xe_2013/tbb/bin$ ls
swapnil@swapnil-lp:/opt/intel/composer_xe_2013/tbb/bin$ cd /opt/intel/composer_xe_2013/ipp/bin/
swapnil@swapnil-lp:/opt/intel/composer_xe_2013/ipp/bin$ ls
intel64 ippvars.csh

I have checked this two file they are present at specified location then why this happen.
What I have to do to set compilervar?
Is it file not found error or any thing else?
Thanks!! :)

Leave a Comment

Please sign in to add a comment. Not a member? Join today