Error during installation of C++ 11.1.067

Error during installation of C++ 11.1.067

Intel C++ 11.1.065 and IVF 11.1.065 worked fine. During installation of C++ 11.1.067 I received the error message during step 5 "Unable to install the integration into Visual Studio...". When I called Visual Studio, I received the error message that the package could not be loaded into VS.

I deinstalled 067, deinstalled the complete VS2005, reinstalled VS2005, SP1 and the follow-up for SP1. When I installed 067 again, I received the same message. When I tried to install 065 again, I received the same error message (screenshot attached). Any suggestions how I can solve that problem?

Environment: Windows 7 IA32 (German), VS2005 (German), C++ 11.1.065 (067), IVF 11.1.065 (067)

AttachmentSize
Downloadimage/png Error_C_065.png96.85 KB
9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Thanks, Om. The solution in the referenced article does not work. There is no environment variable "ENVSDK_REGKEY" on my computer, and I never installed IBM ClearCase. It must be something else.

I've seen a case that the downloaded binary is bad. so try to download again, and extract to a different folder to install.

So the steps would be:
1. uninstall the 11.1.067
2. download and reinstall (be sure to download and extact to a different place in case the old files are bad).

Thanks,
Jennifer

Please let us know if the issue is resolved.

Unfortunately the problem is not resolved. I downloaded 11.1.067 again, and tried to install the package in a different directory than the default directory. The same error occured, again in step 5. I suspect that some C++-related variables are stored in the registry, and the installation procedure gets confused from variables of previous installations. I had that problem some versions ago, when the integration was not loaded when I called VS2005. Steve Lionel was able to fix that problem by fiddling around with the registry, but this time his solution did not work. Unfortunately he is not available until end of September.

A complete reinstallation of VS2005 did not help, either. What can I do? I am becoming desperate.

Hi
With an similar situation , I using media system (upgrade, not media new system)
dummy side to it recreated new register base, without possible the key incoherent .
Generally after i have all proper.
If you make...
Before ,uninstall the VS and Intel Compiler, more sure for new reinstall two compiler after.
Regards

The problem was solved, thanks to the advice of Jennifer.
Everything works fine again, no error messages during installation of the Intel compilers (C++ and Fortran), or execution of VS2005. Something was wrong with the setting of the system environment variable
"path" (too much entries, wrong entry, whatever). Thanks again, Jennifer!

Best Reply

No problem.

Because some others seen the same problem, I'm posting the solution and the rootcause here.

The rootcause: our installation adds the "bin" directories to the "path" environment variable. so after installed many compiler updates, the "path" exceeded the max and the "C:\Windows\system32;C:\Windows;" dirs got pushed out....

The solution:
1. uninstall the last compiler update that has reported the error
2. clean-up the "path" to remove all the bin directories added by Intel Compiler installation.
As for how to clean up, goto the property dialog of "my computer".
make sure the system directories are there.
3. install the compiler update again: it will add the bin dir again. this is so you can run your program without adding the bin dir.

The installation of newer compiler does check the length of "path" if I remember correctly. But I need to verify this.

Jennifer

Leave a Comment

Please sign in to add a comment. Not a member? Join today