openmp

openmp

Hello,

I installed the compiltor of intel

in fact it is compiling but not the execution

icc -openmp prog.c -o prog

./prog

Here are the error message:

error while loading shared libraries: libiomp5.so: can not open shared object file: No such file or directory

i do

icc -openmp -static-intel prog.c -o prog

./prog

I have

OMP: Warning #2: Cannot open message catalog "libiomp5.cat":
OMP: System error #2: No such file or directory
OMP: Hint: Check NLSPATH environment variable, its value is "(null)".
OMP: Hint: Check LANG environment variable, its value is "fr_FR.UTF-8".
OMP: Info #3: Default messages will be used.

Thank you

16 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

-static-intel doesn't affect libiomp5; it is still linked dynamic, unless you set the specific option with -openmp-link, so you must provide the library, and point to it in LD_LIBRARY_PATH (as sourceing the iccvars script does) or by ldconfig. This is a separate question from the one of whether it is possible to change the run-time error messages from English to French.

hello

I am beginner with ubunto
if you tell me please how to access LD_LIBRARY_PATH
Thank you

Hi, salut

LANG=C;

export LANG
KMP_BLOCKTIME=0;

export KMP_BLOCKTIME

LD_LIBRARY_PATH=/opt/intel/Compiler/11.1/059/lib/intel64

export LD_LIBRARY_PATH

cd /opt/intel/ext.................

./icpc -ansi -fast -static -O2 -axSSSE3 -lpthread -openmp -openmp-lib=compat -march=core2 -mtune=core2 ton_prog_source.cc -o (le nom du binaire rsultant)

Kind regards (Cordialement)

I have installed the Intel C++ compiler using default option during install. I use the following to get Intel 64 version of C++ compiler environment:

$source /opt/intel/Compiler/11.1/064/bin/iccvars.sh intel64

The above script sets the environment variable LD_LIBRARY_PATH automatically for you.

$ echo $LD_LIBRARY_PATH

/opt/intel/Compiler/11.1/064/lib/intel64:/opt/intel/Compiler/11.1/064/ipp/em64t/sharedlib:/opt/intel/Compiler/11.1/064/mkl/lib/em64t

The required files are available as given below:

/opt/intel/Compiler/11.1/064/lib/intel64/libiomp5.a

/opt/intel/Compiler/11.1/064/lib/intel64/libiomp5.so

Hello

I do

/opt/intel/Compiler/11.1/064/bin/iccvars.sh intel64
echo $LD_LIBRARY_PATH
:/opt/intel/Compiler/11.1/064/lib/ia32

$LD_LIBRARY_PATH = /opt/intel/Compiler/11.1/064/lib/ia32/libiomp5.so

I have this message

bash: :/opt/intel/Compiler/11.1/064/lib/ia32: Aucun fichier ou dossier de ce type

thanks

If you have installed only the intel64 compiler, the /ia32/ directories won't be present. In any case, should you compile with the intel64 compiler, it will ignore any 32-bit libraries on the search path.

The PATH should not include any individual libraries, only the directories including the libraries. In accordance with the advice given you multiple times, the source commands will take care of setting LD_LIBRARY_PATH. You migh want to check what is there by

> echo $LD_LIBRARY_PATH

but over-writing the setting will remove what was there.

Hello

I do

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/intel/Compiler/11.1/064/lib/ia32/libiomp5.so
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/intel/Compiler/11.1/064/lib/ia32/libiomp5.a

icc -openmp mmv2.c -o mmv2

./mmv2
OMP: Warning #2: Cannot open message catalog "libiomp5.cat":
OMP: System error #2: No such file or directory
OMP: Hint: Check NLSPATH environment variable, its value is "(null)".
OMP: Hint: Check LANG environment variable, its value is "fr_FR.UTF-8".
OMP: Info #3: Default messages will be used.

I do the execution there is the desired result but the warnings persist
how to please because I am limilt by a period

thank you

For the dynamic link with 32-bit libiomp5, at run time you need

LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/intel/Compiler/11.1/064/lib/ia32/

(path to the directory, not including individual libraries, so the entry you quote is superfluous)

For the static link, you could include the full path, including libiomp5.a, in your link step during the build, if you choose not to use the openmp-link option supported by the compiler. Static .a libraries on LD_LIBRARY_PATH will be ignored.

Apparently, you have the correct paths set in addition to the useless entries. The extra entries are not the reason for the warning.

A previous responder suggested LANG and NLSPATH settings to suppress the warnings about lack of support for French language run-time error messages, but of course that would cancel the ability of other applications to display French.

hello

I do all the commande but the same warning persists but it executed well
he does not know the library open mp

OMP: Warning # 2: Can not open message catalog "libiomp5.cat"
OMP: System error # 2: No such file or directory
OMP: Hint: Check environment variable NLSPATH, its value is "(null)".
OMP: Hint: Check LANG environment variable, its value is "en_US.UTF-8".
OMP: Info # 3: Default messages will be used.

How? Please specify me the exact command
thank you very much

Please let me know exact version of libiomp5.so. Set environment variable KMP_VERSION to 1, run your application, and copy its output, for example:

$ export KMP_VERSION=1
$ ./mmv2

Hello

I do

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/opt/intel/Compiler/11.1/064/lib/ia32

icc -openmp mmv2.c -o mmv2

export KMP_VERSION=1

./mmv2

Intel OMP performance library (dynamic) ver. 5.0.20091005 (C) Copyright 1997-2009 by Intel Corporation
Intel OMP library built 2009-10-05 17:36:31 UTC using Intel C++ Compiler 10.1
Intel OMP port library
Intel OMP nested library
Intel OMP alternative compiler support
Intel OMP 3.0 support
Intel OMP sibling library
Intel OMP no tracefile support
Intel OMP no consistency checking support
Intel OMP INTEGER*8 dynamic dispatch support
Intel OMP INTEGER*8 dynamic scheduling support
Intel OMP Helper Thread support
Intel OMP not using thread affinity support
Intel OMP debugger support version 1.1
OMP: Warning #2: Cannot open message catalog "libiomp5.cat":
OMP: System error #2: No such file or directory
OMP: Hint: Check NLSPATH environment variable, its value is "(null)".
OMP: Hint: Check LANG environment variable, its value is "fr_FR.UTF-8".
OMP: Info #3: Default messages will be used.
Intel OMP not using Intel RML support

thank you

Hi thouraya87

Just cut an paste at you shell
first if you have 64 version or second if you have 32

LANG=C;
export LANG
KMP_BLOCKTIME=0;
export KMP_BLOCKTIME
LD_LIBRARY_PATH=/opt/intel/Compiler/11.1/064/lib/intel64;
export LD_LIBRARY_PATH

LANG=C;
export LANG
KMP_BLOCKTIME=0;
export KMP_BLOCKTIME
LD_LIBRARY_PATH=/opt/intel/Compiler/11.1/064/lib/i32;
export LD_LIBRARY_PATH

Move to directory binary icc (/opt/intel/Compiler/11.1/064/bin/ (ia32 or intel64))

./icpc -fPIC -ansi -shared-intel -axSSSE3 -Os -fast -openmp -openmp-lib=compat -openmp-report -march=core2 -mtune=core2 -fomit-frame-pointer source.cc -o binary_result

if problem persisting repeat new install icc compiler better.

Kind regards

hello
After making the command that you have mentioned, I have

ipo: remark #11001: performing single-file optimizations
ipo: remark #11005: generating object file /tmp/ipo_icpc2EGCGU.o
mmv2.c(19): (col. 1) remark: OpenMP DEFINED LOOP WAS PARALLELIZED.

./mmv2

I have the execution well without the warnings

I reinstall or no?

thank you very much

Hi

I reinstall or no?

no same it work now ..

Now make or search well sample for take practice.

good luck

Kind regards

Hello

Thank you very much

:-)

Leave a Comment

Please sign in to add a comment. Not a member? Join today