11.1.080 Install Error Mac OS X 10.6.2?

11.1.080 Install Error Mac OS X 10.6.2?

My apologies in advance if I am using this site incorrectly. I have not used it before.

I recently received email notification of an update to the Professional c++ compiler for Mac OS X. I downloaded the install imagem_cproc_p_11.1.080.dmg and ran the installer from an admin account. Following agreement to the license terms, I received this message: "Packaging error, Aborting the install." Has anyone else seen this, or does anyone have a suggestion as to how it may be avoided? I might also note that for amusement I tried running the upgrade installation from a regular user account. In this case, the installer did not ask for admin authorization as it should have. Instead, it just bombed with the note that it needed to be able to write to /tmp (as I recall) and /Users/Shared/Library/Application Support/Intel, or at least a close approximation of the latter. (Where the license file is.) I am very tempted to conclude that this installer is broken, but would be happy to learn that I'm wrong. Ordinarily, Mac OS installs simply work. -Thanks. RW

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Quoting - Qale (Intel)

Regarding the "packaging error", I have seen this error once before. I was not able to reproduce the problem though.

Installation should only be installed using the .dmg disk image. Another userhad copied the .mpkg package ontohis hard drive to perform the install on aremote systems ... apparently this just doesn't work well especially when "spaces" are in the folder names in the path.

BTW, if you go to System Preferences -> Accounts -> ctrl-click -> Advance option

1) What do you get for User ID, and Group?
2) What version of the 10.6.2 OS are you using,client or server?

Quoting - wellerra

I am sorry, but your installer is broken. Your comment about not moving the installer from the .dmg file was a clue. The installer is looking for files on a hard coded path that begins at /Volumes. I looked in the system log and found that the 080 installer was looking for files in the 076 tree instead of the 080 tree. Someone cloned the old installer but it didn't get fully updated.You must have had something resembling the 076 tree mounted simultaneously in order for the 080 installer (as posted) to work for you. It is possible to fake this installer out and demonstrate that I am right, but the correct fix is to repair the installer and post a new .dmg. Regards, RW

Quoting - wellerra

I definitely do not have 11.1.076 mount simultaneously during installation of 11.1.080, but I did have it installed previously. Thanks for the pointer, we will look into it.

I assume that you did not have any problem installing with 11.1.076 correct? Just 11.1.080?

Quoting - Qale (Intel)

I uninstall 11.1.076 and made sure that it's not mounted simultaneously. I mounted 11.1.080 and the installation works fine.

1) doub click on .dmg to mount image.
2) double click on m_cproc_p_11.1.080.mpkg
3) Complete installation.

I looked as the console log, and there's no reference to the 11.1.076 tree. Did you clear out the system log messages before the installation of 11.1.080?

1) Did you install 11.1.076 earlier with the same user account that you are using to install 11.1.80?
2) Can you take a look at the file /tmp/intel_temp.plist and see if the content contains 11.1.080? Everytime you run the installation, this file should be overwritten.

Can you provide steps that you went through to do the installation?

Quoting - wellerra
Ok. Finally, I think I understand exactly what happened. When 076 was installed, it left a plist in /tmp. With this 076 plist present in tmp, the second install mistakenly looked for files in an 076 tree under /Volumes instead of the /080 tree. Since there was no 076 tree, the installer bombed. When I renamed the plist and ran the install again, everything worked correctly. I then removed both 076 and 080 with the uninstallers in both Developer/opt and /opt, and cleaned out /tmp. Finally, I reinstalled 080 again. Everything went smoothly. I would strongly suggest that the installer ignore or delete any previous plist in tmp. I did the 080 upgrade sufficiently soon after the original 076 install that the Intel plist was still there. That vestigial file in /tmp really broke the process. We don't ever assume that the data in /tmp is valid across operations. For that reason, I'm really surprised that you used those data. Could it be that this is, after all, a latent bug that only appeared because I installed 080 so recently after having first installed 076?
I have one final question. I see that the compiler appears both in /Developer/opt and /opt. Is it hard linked, or are there really two copies installed in different places?
Thanks for the quick response and the help in getting this sorted out.

Quoting - wellerra

There really are two copies of the compiler installed in the two locations. In the past, they were hard links. The changes was made because /Developer (Xcode tree) can be drag and drop anywhere after installation, and it still works. In order to support this feature, we needed to install a copy of the compiler under the /Developer trees so that the intel compiler also goes along with Xcode.

The compiler installed under /opt is for command line use, and the copy under /Developer will be use with Xcode.

Leave a Comment

Please sign in to add a comment. Not a member? Join today