Novice problem: relink (solved)

Novice problem: relink (solved)

Hi,

Im trying to compile libxfcegui (xfce desktop manager for linux) and i get this error, while executing 'make install' which i dont know how to solve:

libtool: relink: icc -shared .libs/libxfce4kbd_private_la-xfce-shortcuts-provider.o .libs/libxfce4kbd_private_la-xfce-shortcuts-grabber.o .libs/libxfce4kbd_private_la-xfce-shortcut-dialog.o .libs/libxfce4kbd_private_la-xfce-shortcuts.o -L/usr/local/lib -lxfcegui4 -L/usr/lib -lstartup-notification-1 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lpangoft2-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lgio-2.0 -lcairo -lpango-1.0 -lfreetype -lz -lfontconfig -lgmodule-2.0 -lSM -lICE -lX11 -lxfce4util -L/lib -lxfconf-0 -ldbus-glib-1 -ldbus-1 -lpthread -lrt -lgobject-2.0 -lglib-2.0 -Wl,-O1 -Wl,-soname -Wl,libxfce4kbd-private.so.5 -Wl,-version-script -Wl,.libs/libxfce4kbd-private.ver -o .libs/libxfce4kbd-private.so.5.0.0
/home/hexbase/icc/xfce/3_libxfcegui4-4.6.1/libtool: line 7303: icc: command not found
libtool: install: error: relink `libxfce4kbd-private.la' with the above command before installing it

I had configured it to use icc and the 'make' process went well.

Edit:
I solved the problem using this primitive workaround, since im pretty new to linux:
Open the libtool file with a text editor.
Go to the line that appears in the error. Eg: /home/hexbase/icc/xfce/3_libxfcegui4-4.6.1/libtool: line 7303.
Where it says eval "$cmd", replace with: eval "source path_to_compiler/bin/iccvars.sh your_arch && $cmd"
Replace path_to_compiler with the proper path. Eg: /opt/intel/Compiler/11.1/064
And replace your_arch with the proper arch:Eg: ia32
Now run make again and the problem is solved.

Thanks

1 post / 0 new
For more complete information about compiler optimizations, see our Optimization Notice.