-m32 compiler option

-m32 compiler option

I am running linux on an intel 64 machine and my intel compiler is version 10.0.023. I would like to compile 32-bit code on this machine. With gcc, this can be accomplished with the -m32 compiler option. According to the documentation, intel also supports this option, but when I attempt to compile it states

"option '-m32' not supported"

Any ideas as to what is going on? I am also using the -g and -static options.

Dan

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Dan,

Sorry this wasn't more clear. On Linux, icc/icpc doesn't support -m32 or -m64 options as we have different compilers for 32 and 64-bit applications. If you installed the compiler on a 64-bit machine, by default we should install both 32 and 64-bit compilers which will be located in /opt/intel/cc/10.1.013/bin/icc (32-bit compiler) and /opt/intel/cce/10.1.013/bin/icc (64-bit compiler). Weare looking at supporting-m32 in a future release.

Best regards,

JohnO

Thanks for the quick reply. I tried pointing everything to the cc (as opposed to the cce) directory and it worked like a charm.

Thanks!

Leave a Comment

Please sign in to add a comment. Not a member? Join today