'sudo make install'->"icpc" command not found :S

'sudo make install'->"icpc" command not found :S

Hello.
I've been trying o compile some packages like OenEXR, OpenCV... with Intel C++ Compiler on Linux. The compilation is succesfull but then, when I type

$sudo make install

I have an error: " 'icpc' command not found ", but I can invoque icp from my shell with no problems. I'm not a Linux shell expert so I hope anyone in this forum could help me. Please!....

I'm using Ubuntu.

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Your sudo command opens a new shell without copying your environment variables. If you need icpc in that shell, you will need to repeat the icc enviroment setup in that shell. Choose the appropriate iccvars.sh or csh.

Hello.
I've tried first adding this lines to /etc/profile:
$export PATH=/opt/intel/cc/my-vers/bin
$export LD_LIBRARY_PATH=/opt/opt/intel/cc/my-vers/bin

then I run sudo make install from my user account, then from sudo and i had the same error. Then, as sudo(sudo -i) i run iccvars.sh, and I had the same error :S.

please, help me:(

LD_LIBRARY_PATH should contain /opt/intel/cc/version/lib
If your install went correctly, your iccvars.sh should contain the correct settings.

Leave a Comment

Please sign in to add a comment. Not a member? Join today