-opt-malloc-options beingi overriden

-opt-malloc-options beingi overriden

I have an issue with icc 10.0.026 on linux SLES10-sp1 , where the -opt-malloc-options is overriden by the "-o " output file option and vice versa. For example when compiling a single source file with:

icc -c -o matrix.o -fast -unroll4 -Ob0 -prefetch -opt-malloc-options=3 -opt-streaming-stores always -vec-guard-write -parallel -par-runtime-control matrix.c

I get:
icc: command line warning #10122: overriding '-opt-malloc-options=3' with '-omatrix.o'

Then I tried changing the order of "-o matrix.o" and "-opt-malloc-options=", i.e. having "-opt-malloc-options" last on the command line. Now -omatrix.o is being overriden and the object file created is named "pt-malloc-options=3"

Is -opt-malloc-options an actual optimization? If yes, why is it being confused with the -o output option? Can I find a patch / fix for this?

I also tried compiling and linking all sources on the same command line, the results are identical.

thanks for your time,

- Vasili

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

These compiler flags are used by Intel and several other companies for a SPEC CPU2006 benchmark run of a benchmark named 462.libquantum .I did not make up these flags.
Here's the link to the benchmark score and the flags used (look for libuquantum under peak optimization flags):

http://www.spec.org/cpu2006/results/res2007q4/cpu2006-20070917-02085.html
http://www.spec.org/cpu2006/results/res2007q4/cpu2006-20070917-02085.txt

I was trying to reproduce the performance reported but I have not been able to - I am getting a much bigger execution time with my compilation. I was wondering if opt-malloc-options=3 would make for the difference.

Leave a Comment

Please sign in to add a comment. Not a member? Join today