Intel C++ Compiler 9.1 Does Not Integrate with VS2005 properly

Intel C++ Compiler 9.1 Does Not Integrate with VS2005 properly


I downloaded Intel C++ Compiler for Windows Version 9.1.022. The install process recognizes that Visual Studio Version 2005 is installed on the machine. When Administrator user works, Intel C++ compiler works from Visual Studio 2005 integrated environment properly. But when I try to works as a normal user and start Visual Studio 2005 I get message:


Package Load Failure

Package Intel C++ Compiler Integration Package, Tool Option has failed load properly (GUID={477A1EE1-A43E-4250-A512-A0DF1F30891E})


Then I ignore this message the Visual Studio 2005 works but without options added by Intel C++ Compiler.

I have tried to uninstall and install Intel C++ two times but this message appears every time. I have tried to install on another computer, but the result was the same.

I am running Windows XP Professional (SP 2).

Could someone tell me what is wrong in Intel C++ Compiler for Windows Version 9.1?

Previously I used Visual Studio Version 2003 plus Intel C++ Compiler Version 9.0 and all worked good.


17 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

It looks like a bug. I'll report it.

I also found a work around in this case.
1. export [HKEY_CURRENT_USERSoftwareIntelIDEC++91] to a file "91work.reg" under the admin account.
2. logon with the other user account and import above file "91work.reg".

Then it should work.


The above work around only works with Power users.

So please report it to PremierSupport.

Sorry for the inconvinience.


Jennifer writes:-----------

I also found a work around in this case. 1. export [HKEY_CURRENT_USERSoftwareIntelIDEC++91] to a file "91work.reg" under the admin account. 2. logon with the other user account and import above file "91work.reg".

------------Thank you. It does not work.Jerzy

Jennifer writes:-----------

The above work around only works with Power users.

------------Thank you. But it does not work too.Jerzy

Please file an issue report to Premier Support.

Thank you!



FYI I had some problems with both the C++ and Fortran 9.1 Visual Studio integration installations for both VS 2003 and 2005, and it turned out to be some registry problems. The C++ integration wasn't working correctly in VS2005, while the Fortran integration wouldn't even install -- displaying only a blank window in the screen where you choose the options.

I got to poking around in the registry and discovered that versions 8.x and 9.0 created key "trees" under both HKCU and HKLM, but 9.1 only created the tree under HKCU. It created one key in HKLM for 9.1 (and there was some difference between Fortran 9.1 and C++ 9.1, but I forget), but did not fill in all the subkeys and entries.

I just copied the branches from HKCU to HKLM for both Fortran and C++ and lo and behold everything worked fine. I think one part of the install thinks writes only to HKCU, but another part wasn't updated and looks only in HKLM.

The OP might try copying to HKLM and see if it fixes the problem for him as well.


Please try Richard's work around. I'll follow up.

Thanks for the infoRichard.


Message Edited by jljiang on 05-10-2006 05:30 PM

Jennifer and all,I didn't go into much detail about what I did to get things working, and I'll do that here for the benefit of any others having similiar problems.The problem seems to be that some part of the software is looking for keys under HKEY_LOCAL_MACHINE (HKLM) branch while the installer only puts it under HKEY_CURRENT_USER (HKCU). What I did was just copy the sub-tree from HKCU into HKLM. This will only work after you've tried to install things at least once so the HKCU keys are created.To do this, fire up Regedit and navigate to the following key:HKEY_CURRENT_USERSoftwareIntelCompilersC++91This key and subtree contains all the paths and other information various parts of the package need, apparently.Right click and choose "export" to save this key and all subkeys and values to a file. Once saved, edit the file with a text editor and change all instances of the string "HKEY_CURRENT_USER" to "HKEY_LOCAL_MACHINE". Do this very carefully making sure things are correct.Save and double click the file to import it back into the registry. Thiswill create a copy of the everything under the HKLM branch.For Fortan do the same with the following Fortran key under HKCU:HKEY_CURRENT_USERSoftwareIntelCompilersFortran91I stumbled onto the above by comparing 9.1 to previous versions' registry key and noted that 8.x and 9.0 had the above keys under HKLM, but 9.1 only had keys under HKCU.-Richard

A have done the following operations:

1) I logoned as Administrator.

2) After instalation of C++ from W_CC_P_9.1.022.exe (for all users), I reinstal C++ from w_cc_p_9[1].1.022_IA32.exe.

3) Next I copied keys (using regedit.exe):




to compilers91.reg and IDE91.reg files .

4) I logoned as a normal user and imported keys from compilers91.reg and IDE91.reg files (using regedit.exe).

Now the Intel C++ Compiler 9.1 integrated properly with VS2005 for normal user.:smileyhappy:

Thanks to Jennifer and Richard,


I am trying to get C++ 9.1 integration to work with vs2005. My problem seems to be related but different from the last two posts. The integration information shows up in HKLM but not HKCU for the subkeys: compilers/C++/9.1 and IDE/C++/9.1. Unfortunately copying these keys and subkeys to HKCU doesn't seem to fix the problem. I tried reinstalling the compiler/integration for all users and it didn't help. I also tried it with v 9.0 installed (minus the 9.0 integration) and not installed with no better result. Any ideas?

Did you see the "C++" blue logo on the VS 2005 splash window? Are you able to see the "intel C++" property page in the "Options" dlg?

Try to unregister (maybe 3 times) and re-register the DLLs at C:Program FilesIntelCompilerVS IntegrationC++VS2005 to see if it helps.


Attached a sample HKCR for fyi.

The C++ logo appears in the splash screen. I must be looking at the wrong place in the Options dlg because I don't see Intel Fortran there either and it's working. I tried unregistering and reregistering and so far it hasn't worked. I also at one point when I was in vs got a package load failure error for package "Intel C++ Compiler Integration Package, Tool Option'.


Try this:

1)Logon as normal user,

2)Export of your key:


to file old-Intel.reg,

3) Import keyfromHKLU-IntelC++91.reg.txt file I have attached to this post (on my computers it works),

4) Optionally, delete keys you do not need.


Just a note: Be careful about the path information in the attached registry files. The paths should be where you actually installed the compilers. If this is not "C:Progam Files...." then you'll have a problem. :)

Make sure the complete path information is under both HKCU and HKLM. The x86, x64, and Itanium components all have their own separate keys under the tree with the path info for each. Make sure all of that is there.

Just a thought, but registry permissions might be the source of some of these problems (a bug in the install or something else).



Our dev team has identified one bug and it should be fixed in the coming 9.1 update. So some progress has been made.

Thanks all for helping out.


The registry key didn't work either. I also changed HKCU to HKLM and that also didn't work. As for the path, vs is installed in its default location on C:, but I haven't checked to be sure more than that yet. I think I may uninstall completely and do a manual registry clean of Intel C++ info and try again later. I will look at registry permissions before I do that though. Thanks for the tip there, Richard. Thanks for your help also Jerzy, I will keep trying to get this to work! Btw, does Intel Visual C++ show up in new projects the same as Intel Fortran? That is to say, off the main branch shown. Thanks again.

Leave a Comment

Please sign in to add a comment. Not a member? Join today