-parallel option(libguide.so not found)

-parallel option(libguide.so not found)


I am trying to tune an application on Itanium. when i use -parallel option the executable has the dependency on libguide.so. when i run the executable
i am getting the following error.

"error while loading shared libraries: libguide.so: cannot open shared object file: No such file or directory"

I have set the LD_LIBRARY_PATH and libguide.so is present in that path. I dont know why it's not picking up. when i did ldd on the executable it shows

/hpcsw/apps/linux/ipf/ecc-8.1_010/lib/libguide.so => /hpcsw/apps/linux/ipf/ecc-8.1_010/lib/libguide.so (0x2000000000040000)
libm.so.6.1 => /lib/tls/libm.so.6.1 (0x20000000000b0000)
libguide.so => not found
libpthread.so.0 => /lib/tls/libpthread.so.0 (0x2000000000140000)
libc.so.6.1 => /lib/tls/libc.so.6.1 (0x2000000000170000)
libgcc_s.so.1 => /lib/libgcc_s.so.1 (0x20000000003d8000)
libdl.so.2 => /lib/libdl.so.2 (0x2000000000408000)
/lib/ld-linux-ia64.so.2 => /lib/ld-linux-ia64.so.2 (0x2000000000000000)

I am usingthe following linker"/lib/ld-linux-ia64.so.2 -> ld-2.3.2.so". I tried to do static compilation also, but that too was not successful. Quick reply wil be highly appreciated.

Thanks in advance,

1 post / 0 new
For more complete information about compiler optimizations, see our Optimization Notice.