HELP: internal error

HELP: internal error

Hi,everyone!
I gotanother error when Icompiling my C++ program with 8.0 version.
The error is following:

(0): internal error: backend signals
compilation aborted for xxxxx.cpp (code 4)
Error executing xicl6.exe.

Thanks.

9 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi,

You should consider using icpi which ships with the compiler. This tool helps isolate internal compiler errors. Once you have a small reproducer, can you submit an issue to premier support?

Best regards,

max

Hi,

I am also getting the same error.
Did you get a solution?
Please reply asap

Regards,
Amol Ghanekar

My actual error is :

Compiling...

C:file path....filename.c(39): catastrophic error: could not open source file "ippcore.h"
#include "ippcore.h"
^
compilation aborted for C:...file pathfilename.c (code 4)
Error executing xicl6.exe.

filename.obj - 1 error(s), 0 warning(s)

Hi,

This doesn't look like a compiler internal error. It just looks like the compiler cannot find the include file, ippcore.h.

Are you using IPP with our compiler by any chance? If so, you may need to include the path to the IPP headers on your command line, e.g. -I

Let me know if you are able to get it working.

Regards,

Max

yes, I am doing that.
I am using Visual Studio and in the "project settings" -> C/C++ -> project options, I am giving the path of the header files.

Still I am getting the same error.

It's hard to see the real problem. If you're using a non-English OS, it might relate to a bug in the icl when compiling a file with non-English chars. This bug is already fixed, but the compiler with this fix is not available yet. It should be available by end of this month.

If this is not the case for you, could you submit it to PremierSupport with command line options and a preprocessed file (.i, created by -P).

For the include file issue, you may check the include path, make sure "" is added for directories with space. You can try from a command window to see if it works. (turn the /nologo off, copy the compile command from the output window of the IDE.)

Thanks,
Jennifer

I am trying to compile the c.jpeg file which is located here:
w_ipp-sample-jpeg_p_4.1.007ipp_samplejpegIJGsamplesutils

In the project options under C/C++ tab I have the following

/nologo /MLd /W3 /Gm /GX /ZI /Od /D "WIN32" /D "_DEBUG" /D "_CONSOLE" /D "_MBCS" /Fp"Debug/cjpeg.pch" /YX /Fo"Debug/" /Fd"Debug/" /FD /GZ /c /I "C:Documents and SettingsAmolDesktopw_ipp-sample-jpeg_p_4.1.007ipp_samplejpegIJG_include" /I "C:Documents and SettingsAmolDesktopw_ipp-sample-jpeg_p_4.1.007ipp_samplejpegIJGinclude"

However the error is:
--------------------Configuration: cjpeg - Win32 Debug--------------------
Compiling...
cjpeg.c
C:Documents and SettingsAmolDesktopw_ipp-sample-jpeg_p_4.1.007ipp_samplejpegIJGsamplesutilscjpeg.c(39): catastrophic error: could not open source file "ippcore.h"
#include "ippcore.h"
^
compilation aborted for C:Documents and SettingsAmolDesktopw_ipp-sample-jpeg_p_4.1.007ipp_samplejpegIJGsamplesutilscjpeg.c (code 4)
Error executing xicl6.exe.

cjpeg.obj - 1 error(s), 0 warning(s)

I also searched for the header file ippcore.h but I am not able to find it in the IPP package.

I am using Windows XP English and Visual Studio 6.0

You need to install the IPP product/eval in order to compile the sample. The IPP product/eval will provide the needed .h file.

Jennifer

Leave a Comment

Please sign in to add a comment. Not a member? Join today