Undefined External Symbol error when compiling

Undefined External Symbol error when compiling

I'm trying to get some code to compile with the Intel compiler. I'm using /EHs, /G7, /QxN, /Qip, and /Ot as optimization tags for the compile. This is a large program with many modules. The modules are compiled separately, and then linked later. Each module compiles fine except for one, call it A. A uses modules B,C, and D. B, C, and D all compile fine, but when A compiles, it gives about 16 underfined external symbol errors when linking them all together. I found something online that says this error might happen when using different optimization options for different parts of code compiled at different times, and I thought that was the answer, but I checked that they all use the same options and I still get the errors. The symbols it refers to are in one of the sub-modules. Any ideas how to fix it?

Evan Haas

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Have you tried just"/EHs /O2"?

It seems very specific. It's a good one to report to Premier Support.


Leave a Comment

Please sign in to add a comment. Not a member? Join today