Compiling MPICH with Intel C++ Compiler

Compiling MPICH with Intel C++ Compiler


I've tried to compile Mpich with the Intel Compiler for Linux but the configure fails to use it. It claims that the compiler
doesn't accept ANSI PROTOTYPES

This is the message from configure:


checking that the compiler /usr/local/intel_cc_80/bin/icc accepts ANSI prototypes... no
*# The compiler /usr/local/intel_cc_80/bin/icc does not accept ANSI prototypes


I've tried it including -ansi or -ansi_strict options and I've always got the same result

Has anybody else tried this? Is there an explicit limitation to use other compiler than GCC to compile MPICH?


3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Presumably, you have a config.log which would show what configure test is failing. We have built mpich with the IPF compiler, installed in the default directories. You may wish to check your iccvars script, to see if it is correctly adjusted to the directories you chose for installation, and to see that the adjusted environment variables are in effect when you build mpich.
On ia32 builds of mpi, I generally take the path of least resistance. There is little to choose between builds made with gcc and with icc. I often build mpi with gcc and ifort.

Yes, It was a problem with the environment variables. However, I think I will take your advice about using gcc and ifort


Leave a Comment

Please sign in to add a comment. Not a member? Join today