intel compilers and radhat advanced ws

intel compilers and radhat advanced ws

Hi,

I am using the intel compilers on a dual proc intanium 2 system running redhat advanced workstation beta 2 - taroon.

So far i have got them up and running and have been blown away - very impressive! My app compiles 3-4x faster than gcc, this is quite significant. It also links no problem, but when i try to execute it i get a seg-fault...

I tried the hello.c demo and that works no problem so i know im set up right. But my app is a bit more complex than that...

I am trying to figure out if i need to recompile all the libraries i am using. I statically link everything in to make it easier.

If you have a similar system, you can grab our surce at http://www.jahshaka.com/downloads/jahshaka0911.tar.gz

We use qmake to generate the makefiles so it should be easy to run - the only thing i had to do was to change the mkspec's qmake.conf settings in mkspec/linux-icc to update changes from icc to ecc

Basically, the libs i use are Qt 3.1.x, freetype, opengl and glut. Do i need to recompile all of these?

I have been trying to compile Qt so far with no luck on 3.2 so i downgraded to 3.1 and have no luck there either.

Any help would be greatly appreciated!

thanks,

Jah Shaka

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Is your binutils up to date?
http://www.kernel.org/pub/linux/devel/binutils/

binutils-2.14.90.0.5
has solved some bugs. The binary .rpm is for as2.1 The source version is there as well, in case you want to install a separate version from the old red hat, or build for a different linux version.

Several of us have built gcc-3.1.1, as well as applications built with ecc/efc, using the updated binutils.

If you wish to inquire about support of your version of red hat advanced server, you might file a question on premier.intel.com. I suspect some specific differences have been identified. You may have bitten off more than could be solved with evaluation copies of red hat and Intel compilers.
In principle, if you don't get any link errors, you should be able to use libraries built with gcc.

Hmm,

My binutils is version 2.14.90.0.4-24 not sure if thats still not as up to date as possible... i will try building the 0.5 and see how that goes.

I'm also using the latest intel compiler build - downloaded it from premier.intel.com yesterday... the release before couldnt link with anything

I also found out that the only libs i need to rebuild are c++ ones such as Qt - everything else is c code so it should be ok.

So far i can build most of Qt with make -I (the important parts but leaving out tools like designer), but when i build the Qt test programs they segfault as well... even though they compile and link no problem... weird.

Any further ideas would be greatly appreciated! Maybe someone here running taroon can try and build Qt... only thing ifound on trolltechs website was that i should use -O0

I guess im just happy to know that intel is working on supporting AW3 but couldnt resist betting the beta code running as gcc was just too slow...

the other i noticed was when i did a ldd t1 (t1 is the first tutorial it buiilds and is the simplest one) i notice that

libgcc_s.so.1 is in the list... is this supposed to be there? or is it there because of othe c libs that use it that are linked in such as libX11.so.6...

You are the man :)

I installed the latest binutils rpm for ia64, binutils-2.14.90.0.6 and got Qt to compile no problem. Then i recompiled jahshaka against the new Qt (3.2.1) and it also ran no problem...

thanks!

-jah

Thanks for confirming your recipe for success.

Intel C builds do link against glibc, as you observed. C++ programs might have to be rebuilt, as the Dinkumware STL which comes with ifc/efc-7.1 isn't compatible with libstdc++ provided with g++.

Leave a Comment

Please sign in to add a comment. Not a member? Join today