non-rpm installation on Debian Linux

non-rpm installation on Debian Linux

I am trying to install the C++ and Fortran
compilers on my Debian Linux system.
I have tried following the Intel recommended
procedure, using rpm2cpio, but receive many
errors during this conversion. Has anyone
successfully installed the compilers on
a non-Redhat Linux system and could I find
out from you how this is done?
Thank you for any help you might be able to provide,
David Rangel

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

I'm interested in helping you solve your issue.

Yes, I have gotten a rpm2cpio install to work (not on Debian however). What version of Debian are you running?

What error messages are you seeing?


Compiler Engineering

I run Debian r3.0 (unstable).
I follow the steps at:
I create the directory /opt
then I run the command:
rpm2cpio intel-icc7-7.1-6.i386.rpm | cpio -i

and receive many "no such file" errors, such as:

cpio: ./opt/intel/compiler70/training/templ_im/show_toc.gif: No such file or directory

do you know why this might be happening?

I believe I have reproduced your problem. I was able to get around my issue by doing the following:

Instead of rpm2cpio .rpm | cpio -i

I broke up the command into:
rpm2cpio .rpm > t.cpio
cd /opt
cpio -i /t.cpio

I believe you may have the same issue which is cpio expects you to be in the correct directory.

I will notify the author of the webpage of this discrepancy.

Let me know how it goes.

In addition, while I have your attention: do you know the following about your version of Debian:
Kernel version, glibc version, gcc version.



Slight typo in my command line:

cpio -i < /file

I forgot the <


Leave a Comment

Please sign in to add a comment. Not a member? Join today