Installing Intel C++ Composer 2013 Update 1 on Mac OSX 10.7.4 and XCode 4.5.1

Installing Intel C++ Composer 2013 Update 1 on Mac OSX 10.7.4 and XCode 4.5.1


I've just downloaded Intel Composer 2013 Update 1 and tries to install it on a Mac OSX 10.7.4 with XCode 4.5.1.

I try to initiate the setup and all I get is the follwoing error:

"Could not run startup script.
Error while executing the startup script. Make sure that you have write permissions to /tmp folder and /Users/Shared/Library/Application Support/Intel/Licenses folder"

What's the reason? How can I solve it?


6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.


This may occur due to two reasons
> when a previous installer changes the permissions for a /Users/Shared/Library/Application Support folder, especially when there are more than 1 user on a machine
> Or if you are out of space.

Please verify that you have permissions to write to /Users/Shared/Library/Application Support/Intel/Licenses. If not, changing permissions to this folder should solve this issue.



I had the same problem on a MacBook Pro (OS X 10.8.2, the version of Xcode does not seam to be of importance to my opinion for these problems of rights. I use the command line. Nevertheless my Xcode version was 4.5.1 ) and I have only two users which are me : one does nothing and the other works. So the above explanation by Greeshma does not seam to be the good one. Perhaps the new way Apple considers the security could be a track : I could not install the command line of Cmake a couple of days ago without any explanation of Cmake app. I had no time to try to find which permissions I have to temporarily change if this solution can work.

I have a solution to install the composer 2013 (C++ and also Fortran) changing temporarily the rights. To do that you must be an administrator of you machine. Notice that one must be very careful when using sudo (root user) as one can delete files that admin usres have not access otherwise.

To install both Fortran and C++ updates (and also, before, versions 2011 and then 2013) change temporarily the permissions using the terminal and unix commands:

-> cd "/Users/Shared/Library/Application Support/"
-> cd Intel/
-> sudo chmod 777 Licenses
.... Install both compiler updates via installers on dmg ....
-> sudo chmod 755 Licenses

and that worked for me for each install and upgrade (I have to cheat with chmod each time).

Hope it will work for you.


Thanks Gerard. Yes, the solution Gerard points out, should work. We are still investigating what are all the possible reasons this could be happening. What I mentioned above, are some of the possible reasons.

Is there a way of bypassing the gate keeper on os x 10.8. to install the latest c++ compiler thought of a wrapper in bash to trap all signals.Then I wondered if you can't just kill the gate keeper when it appears. I think of the two the first sounds the best.
What do you think. I someone knows how to disable that piece of genius and the sandbox.

I had no licenses and no directories for them, I created them by hand. I chmod 777 /tmp temporarily. In spite of downloading Xcode twice I fail to have access or locate the files fully logged in as Root. Does anyone know if it is incorporated in xccode the application suite witch is on the paths for the login.

I apologize for the length of this but I was wondering if a wrapper on a program ksh, sh, or zsh running in verbose mode would would trap the executing the code. I have a seventeen year old habit of using ksh for admin tasks.I guess I will just try it and if anyone is interested I can send the test results to them.

Leave a Comment

Please sign in to add a comment. Not a member? Join today