C/C+ Composer XE error #10114

C/C+ Composer XE error #10114


The Intel composer XE 2013 has been installed on my PC (WIN7 64bit).  When compiling an existing C code, I get the following  error:

icl: error #10114: Microsoft Visual C++ not found in path.

That's seems to be correct: we have purchased only the C/C++ compiler.  The VS 2010 was for FORTRAN, and it works well for f90 application.

How do I fix this?

I looked into the PATH variable: there is an address: "C:\Program Files (x86)\Common Files\Microsoft Shared\VSA\10.0\VsaEnv" but there no such a location under that directory.

Have I missed installing something?




Downloadimage/jpeg error-10114.jpg70.59 KB
21 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The VS2010 comes with Intel Visual Fortran is a shell, the Intel C++ Compiler requires the full version of VS2010.
1) if you build your C++ app with Intel C++ from a command line only, the VS2010 is good enough.
2) if you want to use Intel C++ in VS2010 IDE, you need the VS2010 std or above is needed.

I run the compiler from the command line only! That error terminates the compilation. How do I by pass it?

Download and install the free VS2010 exp, or VS2012 exp.
But you need to reinstall the IntelC. so try the steps below:
1. uninstall the Intel Composer XE 2013 for Windows
2. install VS2010 exp or VS2012 exp
3. reinstall Intel Composer XE 2013


a few last questions:
I have uninstalled the whole Composer XE 2013 package, including the Fortran part.
After downloading the VS2010 exp, should I install FORTRAN with the VSSHELL or the one without it ( NOVSSHELL) ?
Will the Intel installer tie the VS2010 with the Fortran and C/C++ compilers or do I have to define the appropriate Env.Vars myself?
Is so could you please provide me with a list of which Env.Vars I have to define ?
Thank you very much for your help.
It is honestly appreciated.

I followed your instructions:
uninstalled everything - basically started from scratch
downloaded VS2010 exp
installed Fortran and C/C++ compilers.
and I still get the same 10114 error !! ???
The old, good and free 'gcc' compiles and links in seconds

Attached are snap shots of my progress.


Downloadimage/jpeg intel-cpp-comp-error.jpg177.13 KB

the problem is that your cmd window is not set up correctly.
Open the cmd window in following steps:
start -> all programs -> Intel Parallel Studio 2013 -> Command Prompt -> Parallel Studio XE with Intel Compiler.... -> IA-32 Visual Studio 2010 mode.

I tired the IA32 cmd window and got the very same error . See attached.
But why IA 32 if I have an Intel 64 machine...???


Downloadimage/jpeg intel-ia32-win-error.jpg195.03 KB

the "ia-32" means the final application binary is an ia-32 app. It is not associated to your machine's x64.
Even on a x64 machine you can build ia-32 app and run ia-32 app.

the problem here is that the script that sets up the env is trying to use the cl from the VS2010 shell directory.

check the cmd property and see if it's: "C:\Windows\SysWOW64\cmd.exe /E:ON /V:ON /K ""C:\Program Files (x86)\Intel\Composer XE 2013\bin\ipsxe-comp-vars.bat" ia32 vs2010"".

you may have "vs2010shell" as parameter.

My second comment,
Does anyone know of encryption support for Mac Os X i.e. AES-NI. I am looking at code with confidential data. I doubt all possible customers will have a system impervious to hacking from an open connection, internally. More importantly is there any support for IOS 6.

Nope! The only two parameters in the cmd prop window are: ia32 and vs2010. See attached snapshot.

I have noticed that the PATH env. variable contains an unexisting sub-directory:
C:\Program Files (x86)\Common Files\Microsoft Shared\VSA\.10.0\VsaEnv . VSA does not exist!!! Maybe this will provide some hint ....


Downloadimage/jpeg ia32-path.jpg46.7 KB
Downloadimage/jpeg ia32-prop.jpg138 KB

Additional comment:
I have just compiled a .f90 subroutine using the command line:
The 'ifort' performs perfectly but via the Intel64 cmd window!!!! When using the ia32 cmd wimdow, compilation terminated with errors. Please see the attached snapshot.

Why then the C/C++ compiler requires a different setup?

The two compilers came within the same package, composer XE 2013, therefore I would expect them to run a similar app. Am I wrong?


Downloadimage/jpeg ifort-intel64-c-record.jpg216.78 KB

Both the Fortran and C++ compilers come in both ia32/x86 and intel64/x64 flavors. You have options to install either or both. Each puts a shortcut on the Start menu which chooses the matching Visual Studio tools, but will not work with mis-matched tools.

From the screen-shot, the Fortran intel-64 build env uses the VS2010 shell.

so the IA-32 cmd env does not then and it has a bug in the script. can you attach the screen shot of the same build env for icl-ia32 and ifort-ia32?


I know that!

Fortran works for me (Intel64) and that is perfect. My problem is that C/C++ compiler does NOT (neither Intel 64 nor ia32). WHY?? What do I miss?
All this sequence of installing and uninstalling processes have not help til now.


also in the icl-ia32 build env, do you see the following?

Intel(R) Inspector XE 2013 (build 250094)
Intel(R) VTune(TM) Amplifier XE 2013 (build 243421)
Intel(R) Parallel Studio XE 2013
Copyright (C) 1985-2012 Intel Corporation. All rights reserved.
Intel(R) Composer XE 2013 Update 1 (package 119)
Setting environment for using Microsoft Visual Studio 2010 x86 tools.

C:\Program Files (x86)\Intel\Composer XE 2013>set VS100COMNTOOLS
VS100COMNTOOLS=C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\Tools\

C:\Program Files (x86)\Intel\Composer XE 2013>set MSVS_VAR_SCRIPT
MSVS_VAR_SCRIPT="C:\Program Files (x86)\Microsoft Visual Studio 10.0\Common7\Tools\..\..\VC\vcvarsall.bat"

C:\Program Files (x86)\Intel\Composer XE 2013>

Where do you want me to look to see these lines? which .bat file?
I don't see them in the cmd win.

Attached are three snapshots of ifort ia-32, ifort Intel64 and icl ia-32. If I can't attach all three, I'll send additional info with the rest.


From the screenshots, the icl-ia32 build env IS trying to access the VS2010 shell. it is why it's broken for the ICL.

But for ifort, it should work.

can you try this?
1) open a cmd window from "Start" and type "cmd"
2) type "set VS100COMNTOOLS" and send the output.

is the output empty for you?


No, it is not empty: Here is the output:
VS100COMNTOOLS=C:\Program Files (x86) \Microsoft Visual Studio 10.0\Tools\

The ia32 does NOT work for ifort. ifort does work when using Intel64 - which I am happy with. I would rather have them both working from the SAME(!) configuration. We are putting so much time and effort into making it work via the ia32.... Can it be done using Intel64 instead?

Update about this issue. It is worked offline and the issue is solved.

See the following article's "resolution 2" for the work-around:


Leave a Comment

Please sign in to add a comment. Not a member? Join today