Error when compiling Boost library

Error when compiling Boost library

Hello,

we get a compiler crash when building Boost library. We build it as follows:

tar -zxvf boost_1_53_0.tar.gz
mv boost_1_53_0  1.53.0i
cd 1.53.0i
  icc -v
  >> icc version 13.0.1 (gcc version 4.1.2 compatibility)
  icpc -v
  >> icpc version 13.0.1 (gcc version 4.1.2 compatibility)
  ./bootstrap.sh \
     --with-toolset=intel-linux \
     --prefix=/uufs/updraft.arches/sys/pkg/boost/1.53.0i \
     --with-libraries=all >& boot.out
  ./bjam --debug-configuration install >& install.out

In the install.out, which is very long, the error is:

common.mkdir bin.v2/libs/math/build/intel-linux/release/threading-multi/../src/tr1
intel-linux.compile.c++.pch bin.v2/libs/math/build/intel-linux/release/threading-multi/../src/tr1/pch.hpp.pchi
icpc: error #10105: /uufs/chpc.utah.edu/sys/pkg/intel/ics/composer_xe_2013.1.117/bin/intel64/mcpcom: core dumped
icpc: error #10106: Fatal error in /uufs/chpc.utah.edu/sys/pkg/intel/ics/composer_xe_2013.1.117/bin/intel64/mcpcom, terminated by unknown signal(135)

We have also tried to build earlier version of Boost, and also tried earlier versions of icpc, but, we get the same error. We are running RedHat EL 5.9.

I appreciate any pointers to what could be wrong.

Thanks,

MC

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Did you try to use Intel C++ compiler for Linux with another C/C++ project? Did it compile sucessfully?

It seems various things could have caused compiler to abort.  Core dump from mcpcom is not common.  Can you repeat that step of the build and look for any additional indications, or submit a problem report?

There have been updates to the compiler since that version, and your g++ version is rather out of date.  Does that step work with the g++?

I was able to build boost 1_53_0 with gcc 4.1.2 according to your directions using a newer version of the 13.0 compiler, I 2nd Tim's suggestion to update your compiler and give it another whirl.

Leave a Comment

Please sign in to add a comment. Not a member? Join today