xilink : error #10014: problem during multi-file optimization compilation (code 1)

xilink : error #10014: problem during multi-file optimization compilation (code 1)

I am using Paralell Studio 2011 with Visual Studio 2010 and i tried to use the Intel C++ compiler instead of the Microsoft one for a medium large project (250 k loc).

The x86 Version builds and runs. The x64 Version stops building with:

2>  Fatal compilation error: Out of memory asking for 2097160.
2>xilink : error #10014: problem during multi-file optimization compilation (code 1)
2>xilink : error #10014: problem during multi-file optimization compilation (code 1)

This is a XP x64 Machine with 14 GB RAM.

I Googled and i found this topic:

http://software.intel.com/en-us/articles/ipo-parallel-switches-internal-...

But going to Project->Properties->C/C++->Debug [Intel C++] i see that

"Enable Parallel Debug Checks" is set to "No".

Also a trial to update parallel studio from

    "Help->Intel parallel Studio 2011->Check for Updates"

results in

    "There are no updates available at the moments"

What is the cause for this problem and what can i doto get around it?

Thanks for any help!

Exact Version Numbers

Microsoft Visual Studio 2010
Version 10.0.40219.1 SP1Rel
Intel® Parallel Advisor 2011 Update 3, (build 186618), Copyright © 2009-2011 Intel Corporation. All rights reserved.
Intel® Parallel Amplifier 2011 Update 5, (build 186533), Copyright © 2009-2011 Intel Corporation. All rights reserved.
Intel® Parallel Composer 2011 Update 6   

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

As the "out of memory" error occurs during your IPO link phase, unsetting /Qipo in your project properties (and a full rebuild) should help.  The Intel64 compiler probably has more aggressive IPO limit defaults than the IA32 one.  You can read about them and modify them if you have time.

There are also options to perform IPO in batches, written up in the compiler documentation.

The parallel build option referred to in the URL you referenced is not the one you checked, but you would have had to enable parallel build yourself to hit that one (it's not on by default).

>>The x86 Version builds and runs. The x64 Version stops building with:
>>
>>2> Fatal compilation error: Out of memory asking for 2097160.

I would expect the opposite case because 32-bit applications on a Windows platform have a 2GB limit. Could you take a look at Virtual Memory settings? ( It is in System applet of Control Panel ). What your current settings are?

I found out now that this is not a problem of the 64-Bit compiler but of the optimizing compiler. The Problem also occurs in the 32 Bit release version.

>>>>...Intel® Parallel Composer 2011 Update 6...
>>
>>...I found out now that this is not a problem of the 64-Bit compiler but of the optimizing compiler. The Problem also
>>occurs in the 32 Bit release version...

Update 6 is Not the latest one ( I use Update 12 ) and you could try to apply Update 12 as well. Here is some information on what I use with VS 2005 Professional Edition:

Intel® C++ Composer XE 2011 Update 12 Integration for Microsoft Visual Studio* 2005, Version 12.1.1114.2005, Copyright© 2002-2012 Intel Corporation

I don't expect to see more Updates for 2011 version of Intel C++ compiler.

Any Idea how to get this update?

at https://registrationcenter.intel.com, you can choose updates which are available under your license.

Information shown there is

Intel® Parallel Studio

  • Intel® Parallel Studio (all tools)

No Downloads

  • Intel® Parallel Amplifier

Update 3    26 May 2010

  • Intel® Parallel Composer

Update 6   19 Apr 2010

  • Intel® Parallel Inspector

Update 2   30 Oct 2009

Also a trial to update parallel studio from

    "Help->Intel parallel Studio 2011->Check for Updates"

results in

    "There are no updates available at the moments"

Leave a Comment

Please sign in to add a comment. Not a member? Join today