1>LINK : fatal error LNK1104: cannot open file 'libmmdd.lib'

1>LINK : fatal error LNK1104: cannot open file 'libmmdd.lib'

1>LINK : fatal error LNK1104: cannot open file 'libmmdd.lib'

Context: Visual Studio 2012 with Intel C++ Compiler XE 13.0  [64-bit

libmmdd.lib appears to be an Intel library.

Where do I find the correct version of 'libmmdd.lib"?

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

>>...Where do I find the correct version of 'libmmdd.lib"?

The library has to be in [ ICCInstallDir ]\Compiler\Lib\Intel64 directory.

Note: The above path is registered by default by Intel C++ compiler installer ( it is assumed that 64-bit compiler is selected for installation ) and if you do not have that path set in Windows environment variables and VS settings than something went wrong during installation of Intel C++ compiler.

just a small fix it is $(ICInstallDir)compiler\lib\intel64

 

@Terry: The Intel® C++ command-line window sets these variables for you automatically or you can do so manually in a new window session by setting the compiler environment by invoking the compilervars.bat file:   <install-dir>\bin\compilervars.bat <arg1> [<arg2>
where arg1 is: 

  • intel64: Compiler and libraries for Intel® 64 architecture only (host and target)
  • ia32: Compiler and libraries for IA-32 architecture only (host and target)
  • ia32_intel64: Compiler running on IA-32 architecture (host) that generates code for Intel® 64 architecture (target) using Intel® 64 architecture libraries

and arg2 is the VS version such as: VS2012

_Kittur

Leave a Comment

Please sign in to add a comment. Not a member? Join today