Crash of latest 13 compiler on OSX 10.8

Crash of latest 13 compiler on OSX 10.8

I just installed the latest Intel 13 comipiler on MAC OSX but it crashes when run. Any suggestionswhat might be wrong? 

Here the details:

lyngby:~ root# icc -V

Intel(R) C Intel(R) 64 Compiler XE for applications running on Intel(R) 64, Version 13.0.3.198 Build 20130606
Copyright (C) 1985-2013 Intel Corporation. All rights reserved.

lyngby:~ root# cat test.c
int main()
{
return ( 1 );
}
lyngby:~ root# icc test.c -o test
Segmentation fault: 11

10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

>>...Segmentation fault: 11

What compiler options did you use? Also, could you take a look at a MAC OSX API manual for a description of error code 11?

As my example 

  icc test.c -o test

all options are shown. This cause a segmentation fault and I assume the code 11 is related to that fault. From it is in my initial post you can do exactly what I did.

Maybe there something special about computer but it is a fairly new machine running OSX 10.8.

  

Quote:

Sergey Kostrov wrote:

>>...Segmentation fault: 11

What compiler options did you use? Also, could you take a look at a MAC OSX API manual for a description of error code 11?

POSIX signal 11 is SIGSEGV, a.k.a segmentation fault a.k.a invalid memory reference.

I do agree that the compiler must generate a segmentation fault. I have seen that on other systems when I run Intel C as nonroot the first time.

But in this case I run it as root. But guess no one has clue what the issue is then. It should work on OSX 10.8 I suppose?

In fact when I run icc under gdb I get

(gdb) run test.c
Starting program: /usr/bin/icc test.c
Reading symbols for shared libraries ++++.................................. done

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x0000000000000000
0x000000010006caf9 in target_mac_requires_clang ()
(gdb)

Can you post a reply with the output from these two commands?

xcodebuild -version

xcode-select -print-path

Hi Erling,

I can't reproduce this. Jeff's questions are appropriate, so if you could answer those, that would be great. I'm following up with our driver developer as well to see if there's anything he can speculate further on.

Brandon Hewitt
Technical Consulting Engineer

For 1:1 technical support: http://premier.intel.com

Software Product Support info: http://www.intel.com/software/support

Now I know what the issue is. When I run

  xcodebuild -version

xcode asks me to accept some license agreements.  After I havde done that things works. 

I never use the commandline version of xcode except when called from Intel.

I know it is an xcode stupidity you most likly do not detect but may you could.

  

Thanks, Erling, for that information. That was what we thought might be happening after looking at the code pointed to by your gdb traceback.

Yes, the compiler will be modified to be to be more robust.

Leave a Comment

Please sign in to add a comment. Not a member? Join today