-QdM -Qmic and include

-QdM -Qmic and include

(On Windows 7 Pro x64 with PS XE 2013 and MS VS 2012)

I am trying to resolve an issue when compiling for MIC native where the include path is not set up correctly. Using one of the sample native applications, which compile "icl -Qmic ...". When compiling without -Qmic the sample program compiles (yes this is posted under a different message), however this is something new. In an attempt to resolve the issue I wanted to add -QdM to display the macros. -QdM is recognized as a valid option when compiling without -Qmic, with -Qmic the compiler complains about invalid option (along with stdio.h not being found).

FYI I also tried SET GXX_INCLUDE=%INCLUDE% as a hack test (as I do not have GCC installed).

Is GCC required to be installed (on Windows) in order to perform native (-Qmic) compilations using ICL?

Jim Dempsey

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Jim, can you try -Qoffload-option,mic,compiler,"options" -- see this link, http://software.intel.com/en-us/node/459712

There's a gcc included in the MPSS stack.

That sets default options, I want to see what default INCLUDE path is.

(minimal) gcc did not come with MPSS 3.1 for Windows. That is likely the issue.

Installed Cygwin

Set GXX_INCLUDE=C:\cygwin64\usr\include

Then compile, stdio.h found, stddef.h not found.

Set GXX_INCLUDE=C:\cygwin64\usr\include;C:\cygwin64\lib\x86_64-mingw32\4.8.1\include

(where stddef.h located)

Still stddef.h not found.

Transposed paths about ";"

stdio.h not found

Apparently multiple paths cannot be specified.

I also set CPATH to the above, same issue.

Any help would be appreciated.

Jim Dempsey


I see you've posted also in the MIC forum, that's a place for these questions.

This link shows how to set up your software for Windows hosted compilations, including MPSS installation: http://software.intel.com/en-us/articles/intel-xeon-phi-coprocessor-developers-quick-start-guide

Leave a Comment

Please sign in to add a comment. Not a member? Join today