c++ 14.0 Optimization is Broken

c++ 14.0 Optimization is Broken


I have code that compiles and runs correctly with C++ 12.1.  However, when I upgrade to C++ 14.0 it does not work.  Values are not correct.  If I turn off optimizations or leave it to minimum size, the code works.  FYI it works if Use the Visual C++ compiler.

Where do I go next?


4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Just as a follow up;

The intel compiler does not warn about unsigned signed mismatch in a for loop.  And the compiler does not compile properly with optmization on.  I had to change those loops and it worked fine.  In 12.1 it worked.  In visual c++ it works either way.

could you send the code snippets or a testcase with it? Or file an issue report at Intel Premier support with your code.

Also are you using the latest icl 14.0 update 1?



@vetrostudios did you hit a case where it was better to use size_t than int for the loop counter?

Leave a Comment

Please sign in to add a comment. Not a member? Join today