Matching Composer version with gcc versions on Linux

Matching Composer version with gcc versions on Linux

For a given version of Intel C++ Composer XE for Linux how can I tell what gcc version(s) are compatible when installing on a Linux distro ?

I am asking this because I believe that Intel C++ on Linux uses the standard C++ library suppied by the gcc version installed and I have run into problems when using Intel C++ because the version of gcc installed seems to be too modern for the version of Intel C++ Composer XE installed and which I am testing. I often have to test multiple version of Intel C++ Composer XE for Linux so while I can sometimes successfully test the latest version, a previous version fails because of incompatibility with the default version of gcc installed.
 

1 post / 0 new
For more complete information about compiler optimizations, see our Optimization Notice.