15.0 release changes support of openmp-simd ?

15.0 release changes support of openmp-simd ?

I received the 15.0 beta termination email today, and noticed that there are 15.0 releases posted on registrationcenter.intel.com.  Perhaps these aren't ready?

I tried first (several times) the Parallel Studio Windows X64 version.  That installer dies repeatably at a stage where it says it is dealing with xml.   I don't know where to find any diagnostic message.

I could download and install the separate C++ for linux and Windows.  On both linux and Windows, an abort like

": internal error: ** segmentation violation signal raised **

compilation aborted for loopsv.c (code 4)

shows when the OpenMP option is set but openmp-simd is not separately disabled, when the source code is set up for 15.0 beta.

The problem cases apparently are both ones where the required pragmas changed from 14.0 to 15.0 beta and now have changed again.

In one case, returning to apparently incorrect usage which works in 14.0 (omitting a max reduction clause), but not in 15.0 beta, overcame the failure.   In another, neither the source versions for 14.0 nor 15.0 beta are working (omp simd lastprivate with and without max reduction clause), but with 15.0 release, the code is optimized without pragma.

Apparently, the Windows installation of individual compilers replaced successfully the older compilers, without requiring separate removal.

I was aware that use of pragma simd or omp simd in cases with max reduction worked only by chance in 14.0, but I hoped that 15.0 would correct it, rather than requiring a new round of tests to see what works.  It seems particularly poor that a change from previous usage provokes internal error rather than an error diagnostic.

Another small issue: the 15.0 compiler drops optimization of cases with unrolled source code, where /Qunroll4 works well if the source unrolling is removed.

11 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Tim,

Thanks for reporting. I'll follow up with your findings soon.

Regards,

Hubert Haberstock

Tim,

We found Installation issues yesterday with old serial numbers (with actual support though) with installing the Intel® Parallel Studio XE Professional Edition for Windows*. Could you please tell me your serial number you used for installation (please answer via "Send Author A Message"). Installing Intel® Parallel Studio XE Composer XE Editions however works.

Regards,

Hubert.

Yes, I was able to install the compilers after downloading them individually.  I sent Hubert my license key.  I suppose its age of 10 months qualifies as old.   I tried adding a freshly downloaded copy of the license in the main license folder, without success.  The install isn't putting up any of the normal licensing pop-ups such as "use existing license?" or requesting license key entry.

I'm not sure I understand the distinction, if any, among Parallel Studio downloads.

The cases which were supported in the beta compiler, which no longer work, involve omp simd reduction(max: ) lastprivate... I have a case where gcc needs this to optimize (as well as some where gcc doesn't need #pragma simd).  The 15.0 release requires either a return to the syntax which worked with 14.0, in one case, although it appeared to be wrong, or taking advantage of the occasional new ability to optimize without pragma (taking advantage of /fp:fast).

 

The entire cluster studio installation completed on my 5 year old Windows 7 machine, although it dies on the recent Windows 8.1.

Tim,

Can you provide a testcase for the omp simd reduction(max: ) lastprivate... which worked with 15.0 Beta (or 14.0) and doesn't any longer with 15.0 release? I'm not aware of any such changes, but a reproduce would show the issues.

Regards, Hubert.

Tim,

It would be helpful if you uploaded a log file from Window 8.1 (via "Send Author A Message") so that we can investigate what went wrong under Windows 8.1.

The log is under %TEMP%\pset_tmp_PSXE2015_<user>\<tag>\log\pid_xxxx.log.

Thanks & regards, Hubert.

 

Hubert,

When I removed the licenses folder, the install created a new one but did not request a license key nor put any files there, and died at the same point processing config.xml.

Log attached.

Thanks,

Tim

 

Attachments: 

AttachmentSize
Downloadapplication/octet-stream pid_5924.log15.92 MB

Tim,

Thanks for the log which is under inspection. We found another Windows 8.1 issue today where a Micorosft hotfix makes problems with several installers (not only Intel). The hotfix is KB2918614 which can break Windows Installer Service.

The only solution for now seems to be to uninstall the hotfix.

Several blogs and forum discussions about this hotfix problem are already out there, for example:

http://answers.microsoft.com/en-us/windows/forum/windows8_1-windows_install/kb2918614-breaks-windows-installer-service/3d75a1c2-114a-4241-a527-35b536edc158

However, it's not sure if the problem you reported is related to this hotfix problem. Investigation of your log file is still ongoing.

Regards, Hubert.

Removing that KB hotfix makes no difference to the installation from the expanded files.  I've started a repeat expansion of the full download which I will try later.

Tim,

Inspection of your log file showed that you have a corrupt Vtune Amplifier XE 2013 Update 15 Installation on your system. The Parallel Studio XE 2015 installer cannot handle this.
Therefore, please could you install Amplifier XE 2013 Update 15 again and then uninstall it again and then try the Parallel Studio XE 2015 installer again. I'm sorry for the inconvenience.

Sorry, it was just a hint with the KB hotfix. You can install it again of course after successfl Parallel Studio XE 20115 Installation.

Hubert.
 

Leave a Comment

Please sign in to add a comment. Not a member? Join today