Cilk on CentOS

Cilk on CentOS

We had to make a major change and move from the Ubuntu operating system to CentOS (a version of Redhat). I am now tryng ti re-install Cilk ComposerC++ XE on CentOS.

It installed on Ubuntu, but installing on CentOS I have had some snags.

Please note thatthis is 64-biy CentOS, but I am installing 32-bit Cilk. The version is CentOS 6.2, 64 bit.

Idid have to make SeLinux permissive,and that worked. I contnued with the install andit said:

32-bit libraries not found on ths system
This product release the presenceof 32-bit compatibility libraries when running on Intel 64 architecture systems. One or more of these libaries could not be found:

libstdc+ (including libstdc++6)

Without these libraries, the compiler will not function properly.

Now I can compile with the gcc command - no problem. During theinstall Iwas told that I had an unsupported operating system, but was given the choice to continue anyway. Since CentOS is Redhat Linux, I chose to ignore message and continue and until the error outlined above everything was okay.

Again, these points should be noted.

64-bit centos ver. 6.2
32-bit compiler for gcc, compiles easily with only gcc
but gave error outlined above during install.

Any help appreciated. Thanks in advance.

I saw something on the internet that the files might be there they just might not be linked.
Any thoughts on this?


3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Nevermid this problem is solved.I just had to download one additional file. It worked.


Hello Newport_j,

I have a similar problem now. I'm trying to install cilk in CentOS.

¿How did you solve your problem?

Leave a Comment

Please sign in to add a comment. Not a member? Join today