Linux make install is putting libraries in the wrong place!

Linux make install is putting libraries in the wrong place!

I have two nearly identical 64-bit Linux systems, one of which runs OpenSuSE 12.1 and the other 11.4.  Running an identical build script on both has different effects, neither of which is entirely correct.  Under 12.1, it builds the 64-bit libraries correctly, but does not build the 32-bit cilkrts or tsan ones, which is a very minor problem as I regard 32-bit as obsolete for such systems.  Under 11.4, it does the same, but also installs the cilkrts libraries into the 32-bit directory!  There is a difference in the build output, where they say (respectively):

Libraries have been installed in:
   /home/nmm/CilkPlus/lib64/../lib64

Libraries have been installed in:
   /home/nmm/CilkPlus/lib/../lib64

Manually moving the libraries into the right directory works.  The build script is:

#!/bin/sh
set -eux
export PATH=/home/nmm/GCC/bin:$PATH
svn update svn://gcc.gnu.org/svn/gcc/branches/cilkplus
# mkdir object /home/nmm/CilkPlus
cd object
../configure --prefix=/home/nmm/CilkPlus --disable-bootstrap  \
    --enable-languages=c,c++,fortran \
    --enable-werror=yes --disable-decimal-float
#   --enable-werror=yes --enable-checking=all --disable-decimal-float
make
make install

and the update script is:

#!/bin/sh
set -eux
export PATH=/home/nmm/GCC/bin:$PATH
svn update
cd object
make
make install

I can easily insert diagnostics into the building mechanism, if that would help.

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

We have found a fix for this issue. I am currently testing it and as soon as it is finished I will put one out.

Thanks,

Balaji V. Iyer.

Hello Nick M.,

   This issue should be fixed in SVN version: r201449.

Thanks,

Balaji V. Iyer.

 

Leave a Comment

Please sign in to add a comment. Not a member? Join today