cilk plus compiler error

cilk plus compiler error

I have this error and I have no idea where to proceed from here. This is after envoking make for the cilk plus complier

checking for i686-pc-linux-gnu-gcc... /home/cute_rj/gcc-cilk-obj/./gcc/xgcc -B/home/cute_rj/gcc-cilk-obj/./gcc/ -B/home/cute_rj/gcc-cilk/i686-pc-linux-gnu/bin/ -B/home/cute_rj/gcc-cilk/i686-pc-linux-gnu/lib/ -isystem /home/cute_rj/gcc-cilk/i686-pc-linux-gnu/include -isystem /home/cute_rj/gcc-cilk/i686-pc-linux-gnu/sys-include checking for suffix of object files... configure: error: in `/home/cute_rj/gcc-cilk-obj/i686-pc-linux-gnu/libgcc': configure: error: cannot compute suffix of object files: cannot compile See `config.log' for more details. make[2]: *** [configure-stage1-target-libgcc] Error 1 make[2]: Leaving directory `/home/cute_rj/gcc-cilk-obj' make[1]: *** [stage1-bubble] Error 2 make[1]: Leaving directory `/home/cute_rj/gcc-cilk-obj' make: *** [all] Error 2

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

The problem is, I think, that cmake, or whatever is generating the config file is hiding (/dev/null'ing) the make errors, so you will have to dig for them. In any case, I have had the most success installing cilk not by svn'ing, but by downloading the snapshot (;a=tree;h=refs/heads/cilkplus;hb=refs/heads/cilkplus), then going to the contrib/ folder and doing download dependencies from there. Then I configure with

 ../cilkplus-gcc/configure --prefix=/opt/gcc-cilk --enable-languages="c,c++" --disable-multilib

and then make;make install

Hope this helps somewhat.

Leave a Comment

Please sign in to add a comment. Not a member? Join today