Cilk Sample programs can not run in Linux due to cilk rts shared libary not found

Cilk Sample programs can not run in Linux due to cilk rts shared libary not found

I installed Intel Parallel Studio 2011 under /opt/intel in Linux 64-bit Ubuntu 11.10.
I found the sample programs buried under /opt/intel/composer_xe_2011_sp1.7.256/samples/en_US/C++/cilk_samples

I managed to build the qsort example, but it does not load since it can not find the cilk run-time system.
I get the following error after having build it with the sample Makefile (make qsort):

ubuntu > qsort
qsort: error while loading shared libraries: cannot open shared object file: No such file or directory
ubuntu > ldd qosrt
ldd: ./qosrt: No such file or directory
ubuntu > ldd qsort => (0x00007fff793ff000) => not found => /lib/x86_64-linux-gnu/ (0x00007f4aa46e6000) => /usr/lib/x86_64-linux-gnu/ (0x00007f4aa43de000) => /lib/x86_64-linux-gnu/ (0x00007f4aa41c8000) => /lib/x86_64-linux-gnu/ (0x00007f4aa3e29000) => /lib/x86_64-linux-gnu/ (0x00007f4aa3c24000)
/lib64/ (0x00007f4aa498c000)

How do I tell the system where to find this file? Do I need to set LD_LIBRARY_PATH? I tried doing so, but it did not help. This file on my system is located under:

On a side note (in case this helps with the above)....
The release notes which seem to be incorrect and need an update to match this release:

First comment would be that since these are where one starts, couldn't these be in a more obvious spot?! Release notes do not tell you where they are, just that say that they are under INSTALLDIR/examples/qsort. For some reason, the release notes do not align at all - are they old and need updating?

Second comment was that the bashrc PATH variable was not set to include a path to the cilk compiler. The release notes indicate that it should be called cilkpp, but this file does not exist and the compiler is now called icpc. Only vtune was added automatically to my PATH variable by the script.

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

You seem to be confusing the Cilk++ WhatIf kit and the Intel Parallel Studio product. The Cilk++ compiler was named cilkpp. As you noted, the Intel C/C++ compiler is named icpc.

Comments on the installation of Parallel Studio should be put into the Parallel Studio forum:

Defining the LD_LIBRARY_PATH environment variable should allow you to add to the directories the loader uses. For example, the following bash command should work for you:

export LD_LIBRARY_PATH=/opt/intel/composer_xe_2011_sp1.7.256/compiler/lib/intel64:$LD_LIBRARY_PATH

- Barry

Thanks Barry, I did load the Parallel Studio, but it sounds like what I might really want is the Cilk++ Whatif kit. Where do I find that?

The Intel Cilk++ kit is available here at . However, The Intel Cilk++ kit is about 2 years old now and not likely to get any updates. It was provided as a stop-gap while we developed the new version. While we'll answer questions on it if we can, we'd really prefer you to be using the supported product.

Intel Cilk Plus is the supported implementation in the Intel C/C++ compiler. A document on converting from Cilk++ is available at

In addition, a GCC implementation is being developed in GCC 4.7. Information about that release is available at the Cilk website.

- Barry

Where do I get the Intel Cilk Plus download?

I downloaded theIntel Parallel Studio XE 2011 for Windows but it does not work properly with Virtual Studio 2010 Express. It said it installed correctly, but failed to add the "Intel C++" as a platform tool set option. While it worked for a friend of mine, who was able to select this option, it does not appear on my system. No idea why. :(

Intel Cilk Plus is distributed as part of Intel Composer, the Intel C/C++ compiler.

Microsoft gives away the Visual Studio Express editions for free. As a result, they come with limitations. I believe that one of the things that is disabled issupport for macros, addins and packages.

This is something you should ask about in the Parallel Studio forum.

- Barry

I have heard that about addins being disabled, but a friend of mine recently downloaded Composer and it installed the Intel C/C++ as an option correctly. It seems to be more of a system issue. The folklore on the web is that if you this issue happens then you need to un-install Composer, and manually delete all the registry entries, then reinstall.

I was quite afraid to monkey with my registry entries, so I was hoping someone at Intel might have better insight into this.

Using the Cilk gcc branch might be an option for me, but I have never build gcc before so this option scares me (although I don't mind using Linux if that is what it takes to get cilk working).

I had downloaded Composer XE for Linux, but haven't had much success with it so far. While it installs, it does not set up the PATH nor the LD_LIBRARY_PATHs correctly in order to build successfully.

I am keen to use Cilk, but the learning path is steep.

Thanks for any insight and advice you can give me.
Scott K

Hi Scott,

The release notes are misleading on this topic, but Express Editions of Microsoft Visual Studio* do not support plugins and as such we can't integrate into them. You'll need to use a Standard Edition or higher to do IDE builds with the Intel compiler. Note that you can still use the compiler from the command line with Express Edition.

The release notes explicitly make this qualification for Visual Studio 2005 and 2008 Express, but not for Visual Studio 2010, so I'll correct that for the next update.

For Linux*, make sure you are running "source compilervars.{sh/csh} {ia32/intel64}" in order to setup the compiler environment appropriately before using the compiler. You can certainly add this setup to your relevant startup file (bashrc for instance) if you'd like.

Some useful links:

Getting started on Windows*:

Getting started on Linux:

Leave a Comment

Please sign in to add a comment. Not a member? Join today