Installed but not Access to Documents and cannot set Env. Vars

Installed but not Access to Documents and cannot set Env. Vars

I installed Intel Cilk Composer XE and it was successful.I tried the two commands that it tells you how to set environmental variables and it did not work.I tried the command to access some quick start documents and that failed.I now just tried to re-install the software and it would not let me - the software was already installed.I just want to set environmental variables and access some quick start documents, but neither worked.First what directory is this software in? I cannot find it.Where can I some quick start docs?How do I set environmental variables? As I said the environmental variables statement:source install-dir/bin/compilervars.csh ia32 does not work for me.Where is the install-dir ?I just want to get started using the documents and Intel Cilk.I have only 30 days.Thanks in advance for any help. Just some to quick start documents form the net should work.Newport_j

5 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Please redirect questions about the Intel Cilk Plus to the forum dedicated to that product at You will get better support there. Besides, it is confusing to discuss product-specific issues like installation of Intel Cilk Plus on this forum, which is dedicated to the (unsupported) Cilk++ kit, since answers about Composer XE do not apply to Cilk++.

To recap:

Intel Cilk++ is a C++-only product developed by Cilk Arts and acquired by Intel. It is unsupported and is provided on Intel's WhatIf site for continuity while Intel integrates Cilk technology into the Intel compiler (aka Parallel Composer). This forum is dedicated to Intel Cilk++.

Intel Cilk Plus is an evolved version of Cilk combined with new array notations and built into the newest versions of Parallel Composer (the Intel compiler). It is a supported product. Product details can be found at The forum for discussing Intel Cilk Plus issues can be found at:

If you do post to the Cilk Plus forum, please makes sure to indicate your platform (Linux or Windows, 32 or 64-bit) and be specifi about how you installed Composer XE, what happens when something "does not work" (i.e., is there an error message?), and anything else that may help the forum monitors to figure out what the problem is. From what you described, it sounds like you can't find where the product was installed and, therefore, cannot do anything else with it. I suspect that if you find the installation directory, everything else will flow from there.

- Pablo

Okay, fair enough I was writing this post late Friday afternoon and in my haste I left out some critical things.Let me state that the try-before-you buy software, that was suggested to me by this Forum, was downloaded and installed successfully. That part went well. The final message was installation of software was complete and successful.There were two statements at the end of the install: let me take the second first. I wanted to find a quick start doc. I tried the statement it gave me.install-dir/Documentation/en-us/documentation_c.htm.The output was:no such file or directoryIt was not a successful command execution. I could not access any docs.If I could do that I am sure all of the other issues would be solved from there by me.When this statement did not work, I tried to reinstall the software.That did not work since the software was previously installed correctly. This was the message that I got when I tried to reinstall the software.So clearly this must be a small problem, something minor that I am failing to do.I thought that I could manually fix this, so I searched the hard drive unsuccessfully for the software. That was also one of the reasons for trying a reinstall. At least this time, I will find out where it was installed.That is all I need, where did it go and I will go from there?I am using Ubuntu 10.04 on a laptop. The CPU is Intel.Thanx in advance for all help.Newport_j

OK, I think that the problem is that the command "install-dir/Documentation/en-us/documentation_c.htm" is not a command in any unix shell that I am aware of. What you need to do is visit the specified file in a browser.

If the installation is giving you incorrect instructions, then you need report that as an installer bug. This forum is not the place to do that. Please visit the Intel Cilk Plus forum of the Composer XE forum. I do not have detailed knowledge of the Cilk Plus installation process. The people who do have that knowledge to not monitor this forum because they do not work with Cilk++.

In general, if you are starting to work with Intel Cilk Plus, I recommend that you subscribe to the correct forum. Although Cilk++ will continue to be around for a while, Intel Cilk Plus is the way forward with Cilk technology.

- Pablo

Installation and kitting problems belong in the Compiler forum:

- Barry

Leave a Comment

Please sign in to add a comment. Not a member? Join today