cilkview error: command exited with error condition: 1

cilkview error: command exited with error condition: 1

It would be really helpful, if there was a manual where all these error conditions were explained. My search has so far been unsuccessful. I am running cilkview for a small FFT program, I get no errors from cilkscreen, and the output seems fine as well. Cilkview however throws me an error:cilkview error: command exited with error condition: 1If I skip the trials option cilkview would generate scalability data and performance analysis but then throw the same error. Incase I put the -trials all option in there with cilkview, the error appears as soon as one run of the program ends.

4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

If I read the Cilkview code correctly, this indicates that your application has exited with a non-zero exit code. Cilkview is assuming that something has gone wrong and aborting the sequence of runs tosave you time.

- Barry

Hi Barry, Can you please help me with this:

I'm using cilk-8503-i686 on Linux(Ubuntu 11.04)....and I called cilkview functions just like the examples did:

int cilk_main(int argc, char** argv)
cilkview: cv;

and I got these errors from linker:
YAM_P.cilk:(.text+0xbd2): undefined reference to `cilk::get_milliseconds()'
YAM_P.cilk:(.text+0xc9c): undefined reference to `cilk::get_milliseconds()'
YAM_P.cilk:(.text+0xe41): undefined reference to `__cilkview_dump'
collect2: ld returned 1 exit status

I've made up some simpler codes to test cilkview and it worked very well...
But what's wrong with this one????

One post would have been sufficient. We (the Cilk runtime team) watch both this forum and the Intel Cilk Plus one.

You need to link with the cilkutil static library.

- Barry

Leave a Comment

Please sign in to add a comment. Not a member? Join today