Trace Analyzer Segmentation Fault

Trace Analyzer Segmentation Fault

Whenever I run my code with 2 or 4 processes, the trace analyzer works fine. However, if I run my code on 6 or more processors, when I run the trace analyzer gui with the created .stf file, it works for a few seconds but soon after crashes with a segmentation fault. Are there limitations associated with the trace analyzer? Or is it more likely a limitation caused my system?Thanks in advance!KS

6 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi KS,

Could you please attach the trace file for further investigation? It's rather TraceAnalyzer's issue but we need to check it. BTW, Linux or Windows version? And good to know ITAC version as well.

Regards!
---Dmitry

Thanks for the response!I'm running the linux version, here's the build #:l_itac_p_8.0.3.04_intel64I attached the trace files associated with with one of the runs causing the GUI to seg fault.-Kevin

Sorry, Kevin,
I don't see any attachment.

Regards!
---Dmitry

Ah, I uploaded but didn't attach, should be there now! Sorry for the inconvenience!

Attachments: 

AttachmentSize
Downloadapplication/x-gtar traceFiles.tgz187.54 MB

Hi Kevin,

Thanks for the trace! I could reproduce the issue with ITAC 8.0 Update 3.
I've tested the same scenario with version 8.1 and there was no crash. Hopefully the issue has been fixed.
Version 8.1 is not available for download yet, but I hope that it will be some time this Fall.

Best wishes!
---Dmitry

Leave a Comment

Please sign in to add a comment. Not a member? Join today