mpdboot only running on 4 nodes

mpdboot only running on 4 nodes


When I run mpdboot (revision 1.4.9) with a number of hosts greater than 4 only 4 mpd instances are started on hosts. e.g. mpdboot -n 8 -v will only launch 4 mpd on hosts. My mpd.hosts file has 19 hosts in it. However if I run mpdboot -n 19 --maxbranch 18 then mpd starts on all hosts as expected. Unfortunately I am not very familiar with HPCs and I see lots of examples of mpdboot with the number of hosts great than 4 without the maxbranch option. Is this a problem with my configuration or can I ignore it and carry on using --maxbranch?

Any help appreciated.


2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Mark,

Sorry, It's not clear - what is your task?

Are you using Intel MPI Library? Current version of the Intel MPI Library is
Usually you don't need to use --maxbranch option - everything should work fine.
Could you provide your mpd.hosts file? What about output with '-v' option?

Please use '-r ssh' option if you are using secure shell (rsh is used by default).

To check mpd ring please use 'mpdtrace' utility.


Leave a Comment

Please sign in to add a comment. Not a member? Join today