Running NPB3.3 with I-MPI

Running NPB3.3 with I-MPI

HiI am trying to run NAS with I-MPI version 3.2.1.The following is the command:mpiexec -rr -n 256 -env I_MPI_FALLBACK_DEVICE 0 -env I_MPI_DYNAMIC_CONNECTION disable-env I_MPI_USE_RENDEZVOUS_RDMA_WRITE 1 -env I_MPI_DEVICE rdssm:ofa-v2-ib0 /home/NPB3.3/NPB3.3-MPI/bin/bt.A.256I am getting error:[0] ERROR - MPI startup(): dlopen() of dat library failed[1] ERROR - MPI startup(): dlopen() of dat library failed.....[255] ERROR - MPI startup(): dlopen() of dat library failed[1] DAPL provider is not found and fallback device is not enabled[0] DAPL provider is not found and fallback device is not enabled[cli_0]: aborting job:Fatal error in MPI_Init: Other MPI error, error stack:MPIR_Init_thread(283): Initialization failedMPIDD_Init(98).......: channel initialization failedMPIDI_CH3_Init(163)..: generic failure with errno = -1(unknown)(): --------------------------------------------------------------------------------------But I am able to run IMB over the same setup, with the same command:mpiexec -rr -n 256 -env I_MPI_FALLBACK_DEVICE 0 -env I_MPI_DYNAMIC_CONNECTION disable -env I_MPI_USE_RENDEZVOUS_RDMA_WRITE 1 -env I_MPI_DEVICE rdssm:ofa-v2-ib0 /home/bin_imb/intel/IMB-MPI1_impi_gccHow to resolve the problem with NAS benchmark?

2 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Grovershah,

Could you tell me how you compiled /home/NPB3.3/NPB3.3-MPI/bin/bt.A.256?
and what is the difference with /home/bin_imb/intel/IMB-MPI1_impi_gcc?

It seems to me that you used different environment to built these 2 applications.

Regards!
Dmitry

Leave a Comment

Please sign in to add a comment. Not a member? Join today