ifort MPI_FILE_OPEN err with romio testsuite

ifort MPI_FILE_OPEN err with romio testsuite

In MPICH-1.2.6, romio directory, there is a test program called "fcoll_test.f".
The test program run successfully with gcc compiler.
However, with ifort (8.0/8.1) compiler, the program fails.

After debugging, I find that the function MPI_FILE_OPEN fails (ierr is non-zero).
But change the size of character array from 1024 to 200 can solve the problem.

I have found another people with similar experience as me: (in Chinese)

Here is the full program :

Here is the simplier version of the program.

program main
implicit none

include 'mpif.h'

integer nprocs
integer mynod
integer fh, ierr
character*1024 str ! used to store the filename
c character*200 str ! this will work

integer writebuf(1)

call MPI_INIT(ierr)
call MPI_COMM_SIZE(MPI_COMM_WORLD, nprocs, ierr)
call MPI_COMM_RANK(MPI_COMM_WORLD, mynod, ierr)

str = 'test'
writebuf(0) = 0

print *,ierr

call MPI_FINALIZE(ierr)


3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Clotho -

I've tried the test code you've included with the Intel MPI Library and the Intel Fortran version 8.1 compiler on an Itanium cluster. This worked fine for me. What processor architecture were you using that gave you the problems? Have you tried a later version of the MPICH library, such as MPICH2?

-- clay

I test it under EM64T.

Thank you for your advise, I will try MPICH2

Leave a Comment

Please sign in to add a comment. Not a member? Join today