running mpiexec wrapper (windows), issue with credentials

running mpiexec wrapper (windows), issue with credentials

using MPIEXEC wrapper, entered credentials of "administrator" ???
launch failed: CreateProcess(C:\Projects\WS_TESTS\ready_INTELC\WS.exe) on
'' failed, error 487 - Attempt to access invalid address.

I am not using the hostfile so only want to take advantage of the local processors.

using "mpirun -n 8 ws.exe"

User credentials needed to launch processes:
account (domain\user) [QUAxxxxx000\xxxx]:
launch failed: CreateProcess(ws.exe) on '' failed, error
487 - Attempt to access invalid address.

Why is it asking for the above?  I ran the "test" example and everything works fine there.


10 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hi Maurice,

This does not appear to be related to your account credentials.  Just to be certain there are no stray environment variables causing a problem, can you please provide the output from

set I_MPI

James Tullos
Technical Consulting Engineer
Intel® Cluster Tools

Hi James.

Ran the following.

set i_mpi

Ah, I see a problem.  Under Windows*, the command isn't mpirun, it's mpiexec.  Try it again with mpiexec, and see if that works.

Hi James.

It was my mistake entering mpirun on my first comment.  In windows you are correct, it is mpiexec.  Trying mpirun simply returns command not found.

I still get the same issue requesting user name and password.  I also get the same issue using the application wrapper "wmpiexec.exe" windows application.

Please try running this:

mpiexec -genv I_MPI_DEBUG 5 -n 8 ws.exe

And provide the output.  Also, if you could run with the test program as well, to compare the results, that would be helpful.

Find attached the result of the test.

Note: the ws.exe application is 32 bit compiled.  Could not get the 64bit version working at the time.  Was always receiving stack segment fault when trying to run the 64 bit version.  Unfortunately, the compiler was being evaluated and is now expired.  But find attached the results of the test.


Downloadtext/plain mpitest.txt3.11 KB

What version of Windows* are you using?  Is ws.exe a graphical application?

Hi James.

Using 64 bit Windows 7 SP1.  The application is a console application.  It is currently running on the linux platform but using the gnu compiler and its associated opensource libraries.  The exercise was trying to see if we can increase the speed of the inversions by compiling using the intel libraries.  They take weeks to run so saving a day is a benefit (code execution wise).  The linux version (intel evaluation) compiled but was unable to use your BLAS/LAPACK libraries, also came up with segment issues when running so had to use the free linux distributions so ended with the same execution speed.

Unfortunately, I think I would have to look into the source in order to find the issue but have moved on to other projects at the moment.

Thanks for your help



I'm not an expert in MKL, so you'd want to ask about that in their forum.  But my understanding is that it should just be a drop-in replacement.

Let me know when you're back on this project, and we'll take a look at it some more at that time.

Leave a Comment

Please sign in to add a comment. Not a member? Join today