error in compiling FFTW3 with intel compiler

error in compiling FFTW3 with intel compiler

Dear all,

I'm trying to build FFTW3 with intel compiler, according to the guide in FFTW website. I configure FFTW3 as

./configure CC=icc F77=ifort MPICC=mpiicc --enable-mpi

however, error reported as

checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... no
checking whether to build static libraries... yes
checking for ocamlbuild... no
checking for mpicc... /home/loam/intel/compilers_and_libraries_2017.4.196/linux/mpi/intel64/bin/mpiicc
checking for MPI_Init... no
checking for MPI_Init in -lmpi... no
checking for MPI_Init in -lmpich... no
configure: error: could not find mpi library for --enable-mpi

I also tried add 

LDFLAGS=-L/home/loam/intel/compilers_and_libraries_2017.4.196/linux/mpi/intel64/lib

CPPFLAGS=-I/home/loam/intel/compilers_and_libraries_2017.4.196/linux/mpi/intel64/include

but it still didn't work.

Does anyone could give some advices? Thank you!

 

Zone: 

Thread Topic: 

How-To
4 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

As intel mpi is installed the wrapper for icc is mpiicc. If you need the ifort mpi wrapper it's mpiifort or 'mpif90 -fc=ifort'. You should set the environment variables by sourcing both the mpivars and compilervars scripts.

Best Reply

It looks like the soft links are a little muddled in this release because compiler is version 4 and MPI is version 3.  There is no Intel MPI 2017.4.196; however, there are setup scripts in the compiler directory which point there.

Try this generic path to the MPI setup script (it's working for me).

   source /home/loam/intel/compilers_and_libraries/linux/mpi/intel64/bin/mpivars.sh

If that doesn't work, try this.

      /home/loam/intel/compilers_and_libraries_2017.3.191/linux/mpi/intel64/bin/mpivars.sh

Thank you all guys!

Problem solved.

Thank you again~!

Leave a Comment

Please sign in to add a comment. Not a member? Join today