subscribe设置bitrateMultiplier

subscribe设置bitrateMultiplier

subscribe时设置码率参数为1.4和0.6观察下行速度没有任何变化,参数是只针对混合流生效?

7 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

请参考文档中bitrateMultiplier的说明, 如果是通过mediaInfo获取到的信息你会发现forward流获取到的最大值是1,只有mix流才有1.4, 1.6的档位

  • bitrateMultiplier: A number for expected bitrate multiplier. You can find valid bitrate multipliers by calling mediaInfo(). If bitrateMultiplier is specified, qualityLevel will be ignored

用户进入房间后布局发生变化 

stream.on('VideoLayoutChanged', function() {
        L.Logger.info('stream', stream.id(), 'VideoLayoutChanged');
      });

是默认订阅重新混合的流吗,看控制台的消息没有相应的日志,这个部分是在哪里是实现的重新mix,可以在这部分设置码率bitrateMultiplier?

 

有用户进入房间之后mix流的布局发生了变化,比如由原来的两个流合成变成了三个流合成,这个事件是用来通知用户关于这个的变化,客户端并没有重新订阅mix流

function trySubscribeStream(stream) {
    if (stream instanceof Woogeen.RemoteMixedStream) {
      stream.on('VideoLayoutChanged', function() {
        L.Logger.info('stream', stream.id(), 'VideoLayoutChanged');
      });
      if (subscribeMix === 'true') {
        L.Logger.info('subscribing:', stream.id());
        var resolutions = stream.resolutions();
        var videoOpt = true;
        var resolution;
        if (resolutions.length > 1) {
       //   resolution = resolutions[Math.floor(Math.random() * 10) % 2];
          resolution = resolutions[resolutions.length-1];
          videoOpt = {
            resolution: resolution
          };
          L.Logger.info('subscribe stream with option:', resolution);
        }

       conference.subscribe(stream, {

          video: videoOpt,
          bitrateMultiplier:0.6
        }, function() {
          L.Logger.info('subscribed:', stream.id());
          displayStream(stream, resolution);
        }, function(err) {
          L.Logger.error(stream.id(), 'subscribe failed:', err);
        });

 

设置  bitrateMultiplier设置为0.6和1.4,看控制台日志订阅的是进入房间时的混合流,分辨率为最小分辨率,但是下行的速度没有变化,我订阅的流不对吗,设置的参数有问题?定制化镜像的问题帮忙回答一下,不知道如何下手了,谢谢!

 

 

设置码率已经生效,请帮忙回答一下镜像问题,谢谢

镜像问题我们正在跟VCA卡team确认,请耐心等待

Leave a Comment

Please sign in to add a comment. Not a member? Join today