Error: Joining room failed (v.4.2.1), when enabling hardware acceleration

Error: Joining room failed (v.4.2.1), when enabling hardware acceleration

Hello,

Please find the environment:

Operating System: Ubuntu 18.04 Server and CentOS 7.x
Linux Kernel Version: 5.2.7
Browser: Google Chrome Version 77.0.3865.90 (Official Build) (64-bit)
Intel CS for WebRTC Version: 4.2.1
Firewall: No firewall and all ports are opened

We successfully deployed previous versions of Intel CS for WebRTC framework earlier in various environments. When we are trying to install v.4.2.1, we are getting "Joining room failed" error. We tried with default certificate, SSL certificated which is generated with OpenSSL, and also with purchased certificate. I also tried with AWS environment and in our LAN server also. But, getting the same error, when I am executing the https://1.2.3.4:3004 URL in the browser. I am not getting any errors in the log files also, except the below error.

Please find the below error:
Failed to load resource: net::ERR_CONNECTION_CLOSED
Failed to load resource: the server responded with a status of 404 ()
WebSocket connection to 'wss://1.2.3.4:8080/socket.io/?EIO=3&transport=websocket&sid=cw4bbpFEaMcrKI4UAAAA' failed: WebSocket is closed before the connection is established.
server connection failed: Error: Joining room failed

Any help would be really appreciated.

Thank you.

Best Regards,
Chandramouli.
 

8 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Hello Team,

As this issue is a blocking issue, request you to help us to resolve the problem. Any help would be appreciated.

Thank you.

Best Regards,
Chandramouli.

try to create a new room from console and joining using the https://1.2.3.4:3004/?room=RoomID.

Also, have you updated service id and key under basic example folder sampleserver.js file

 

Thanks

Naresh

Hello,

In fact, we no need to update the service id in sampleserver.js file. Because, it is generating the same service id, which is already existing in the sampleserver.js file.

What I noticed is, everything is working fine without hardware acceleration. After installing required dependencies, and enable hardware acceleration, we are getting the above error. Have you tried by enabling the hardware acceleration?

Thank you.

Best Regards,
Chandramouli.

Hello Team,

Any help would be appreciated.

Thank you.

Best Regards,
Chandramouli.

I had problems with this. 

1. Download already compiled 4.2.1 MCU.

2. Do an init-all.sh and DO NOT CHANGE the RabbitMQ password on init. (i assume, you have it default, as i had. If you change it, everything will not work, don't know why). Get the service id and key.

3. After init, i had few problems, the modules had crashed for some reason. To fix this, i had to do install_ffmpeg.sh in following folders: analytics_agent, audio_agent, recording_agent, streaming_agent, video_agent.

4. After this, i installed install_openh264.sh in video_agent folder.

5. start-all.sh, go to console and check the Room ID. Enter https://1.2.3.4:3004/?room=RoomID

Also, you may have errors, because you are accessing self signed certificate. Make your own certificate, do an ./initcert.js in each folder of module. Use https://domain:3004/, instead of https://IP:3004/.

Hello Team,

I can strongly say that the issue is coming, when we enable hardware acceleration. Anybody done with hardware acceleration? Any help would be appreciated.

Thank you.

Best Regards,
Chandramouli.

Hello Team,

Any help would be appreciated.

Thank you.

Best Regards,
Chandramouli.

Leave a Comment

Please sign in to add a comment. Not a member? Join today