qsub output empty?

qsub output empty?


Hi,

A simple script job file (myjob):

cd $PBS_O_WORKDIR
python teste.py

the contents of teste.py:

print('ola')

when I run

>qsub myjob

the contents of output of job file:
########################################################################
#      Date:           Thu May 14 10:47:48 PDT 2020
#    Job ID:           596007.v-qsvr-1.aidevcloud
#      User:           u40563
# Resources:           neednodes=1:batch:ppn=2,nodes=1:batch:ppn=2,walltime=06:00:00
########################################################################

########################################################################
# End of output for job 596007.v-qsvr-1.aidevcloud
# Date: Thu May 14 10:47:52 PDT 2020
########################################################################

what is wrong here? It seems that python code is not executed.

Thanks in advance.
 

12 posts / 0 new

Hi,

Thanks for reaching out to us.
We tried to follow the steps shared by you in Devcloud. We didn't observe any issue as you said and the python file gets executed successfully.(Please refer to the below output we got). It would be better if you share the error file generated (eg: myjob.exxxxx) with us. 

########################################################################
#      Date:           Fri May 15 01:04:06 PDT 2020
#    Job ID:           596581.v-qsvr-1.aidevcloud
#      User:           uXXXXX
# Resources:           neednodes=1:batch:ppn=2,nodes=1:batch:ppn=2,walltime=06:00:00
########################################################################

ola

########################################################################
# End of output for job 596581.v-qsvr-1.aidevcloud
# Date: Fri May 15 01:04:07 PDT 2020
########################################################################

Thanks.


Hi,

I tried again today. The myjob.e596662 file contents:

/var/spool/torque/mom_priv/jobs/596662.v-qsvr-1.aidevcloud.SC: line 2: /home/u40563: Is a directory
 

The output file contents:

########################################################################
#      Date:           Fri May 15 03:37:09 PDT 2020
#    Job ID:           596662.v-qsvr-1.aidevcloud
#      User:           u40563
# Resources:           neednodes=1:batch:ppn=2,nodes=1:batch:ppn=2,walltime=06:00:00
########################################################################

########################################################################
# End of output for job 596662.v-qsvr-1.aidevcloud
# Date: Fri May 15 03:37:12 PDT 2020
########################################################################


Hi Carlos,

We tried to submit a job script with the same steps you followed in two different devcloud account. We couldn't observe the issue that you faced. So, we will inform this to concerned team and get back to you soon.

Thanks.


Yes, I can confirm this is duplicate because I didn't find the original thread in the forum so I tried to post again. Also, I can't use the search function from the forum, it does not search the forum but the whole intel.com domain instead. Thanks.


Are there any updates to this issue? You can reset my account I don't have any sensitive files and I would be very happy to submit queue jobs. Thank you.


Hi Carlos,

We have informed your issue to the Devcloud admin team and awaiting for the response from them. We will give you the updates soon. And we have also closed your duplicated thread.

Thanks.


Hi Carlos,

We are forwarding your case for SME to check, since we couldn't reproduce the issue.


Hi Carlos,

While checking the issue internally, it doesn't seem to be an account issue since you are able to do qsub without any problems.The issue might be in the scripts. Could you please try with the attached job file and python script.[Note: Please copy-paste the content instead of typing]. The results we got:

(base) uXXXX@s001-n049:~/forum_job$ qsub myjob
600167.v-qsvr-1.aidevcloud
(base) uXXXX@s001-n049:~/forum_job$ ls
myjob  myjob.e600167  myjob.o600167  teste.py
(base) uXXXX@s001-n049:~/forum_job$ cat myjob.o600167

########################################################################
#      Date:           Tue May 19 23:59:31 PDT 2020
#    Job ID:           600167.v-qsvr-1.aidevcloud
#      User:           uXXXX 
# Resources:           neednodes=1:batch:ppn=2,nodes=1:batch:ppn=2,walltime=24:00:00
########################################################################

Hello world!!!

########################################################################
# End of output for job 600167.v-qsvr-1.aidevcloud
# Date: Tue May 19 23:59:32 PDT 2020
########################################################################
 

Attachments: 

AttachmentSize
Downloadtext/plain myjob.txt63 bytes
Downloadtext/plain teste.txt25 bytes

Hi Carlos,

Please let me know from where you are doing the job submission,is that from login node or compute node?


Hi,

Thanks for your help. The problem remains and I still get no output.

I am launching qsub from the computer node:

u40563@s001-n002:~$ qsub newjob
600931.v-qsvr-1.aidevcloud

########################################################################
#      Date:           Thu May 21 07:42:23 PDT 2020
#    Job ID:           600931.v-qsvr-1.aidevcloud
#      User:           u40563
# Resources:           neednodes=1:batch:ppn=2,nodes=1:batch:ppn=2,walltime=24:00:00
########################################################################

########################################################################
# End of output for job 600931.v-qsvr-1.aidevcloud
# Date: Thu May 21 07:42:26 PDT 2020
########################################################################
 


Hi Carlos,

Thanks for your response. We have informed this to concerned team and will get back to you with the updates soon.

Leave a Comment

Please sign in to add a comment. Not a member? Join today