conda update to IDP 2018

conda update to IDP 2018

Hi all,

On the web, I see packages frequently updated on the Anaconda Cloud Intel channel, but whenever I tried "conda update …", it never updated anything on my mac yet. I think I set up the channel correctly. Just to be sure, could someone please clarify what is supposed to work under a miniconda environment on macOS 10.13? Has the core Python3, or numpy, pandas or dask been updated in the last 5 weeks? These ones I definitely tried to update.

Thanks!

Laszlo

3 posts / 0 new
Last post
For more complete information about compiler optimizations, see our Optimization Notice.

Because of the upgrade to Python 3.6, only 

conda install python=3.6 -c intel

 would work.

In my case, even that broke down, as jupyterlab raised an UnsatisfiableError.

FWIW, I ended up removing the environment and reinstalling intelpython3_full. I am happy with the up-to-date packages that came with it but rest assured, it did not come with jupyterlab.

Laszlo,

Jupyter for using notebooks is available from the Intel channel, but you are correct that jupyterlab in particular is not. That project is still in preview stage (according to their github readme), so not included in our production release.

You are certainly welcome to try to use the lab in our environment by installing it using conventional methods. If you feel there are problems with our distribution that are causing incompatibilities, please let us know.

Best,
Todd

Leave a Comment

Please sign in to add a comment. Not a member? Join today